cancel
Showing results for 
Search instead for 
Did you mean: 

TestComplete and TestExecute performance problem

Occasional Contributor

TestComplete and TestExecute performance problem

Hello,



I hit on problem related to speed of executing tests with using TestComplete as well as TestExecute tools. This issue exists only on one machine and on second everything behaves correctly. I don't know why, but on first machine every operation takes almost 5 times more time than on the second machine. Moreover configuration of both machines is almost identical - physical machine, Windows Server 2008 R2 Standard, TestComplete and TestExecute in version 9.31, 16 GB of RAM. The only difference is in processor model. The first machine has Intel Xeon X5650@2.67GHz and the second one has Intel Xeon E5620@2.40GHz.



According to above description the only difference is in processor model but this difference is minimal and I think it shouldn't have any impact on performance during test execution.



Can anyone give me any clue what can be wrong on the first machine?



On the first machine TC and TE tools were reinstalled but it didn't help at all. It doesn't matter whether I run tests in TC or TE on the first machine - operations are executed very slow in relation to the second machine (the same project, the same scripts).



Regards,

Michał
16 REPLIES 16
Occasional Contributor

RE: TestComplete and TestExecute performance problem

I performed also tips which are described on http://support.smartbear.com/articles/testcomplete/test-playback-performance-tips/ but nothing has changed.



Regards,

Michal
Community Manager

RE: TestComplete and TestExecute performance problem


Hi Michal,


 


Do you execute the same project on both machines? Compare project settings on each computer.


 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

RE: TestComplete and TestExecute performance problem

Hi Tanya,



Yes, I run exactly the same project on both machines.
Occasional Contributor

RE: TestComplete and TestExecute performance problem

Hi Michal,



the softwares like .NET framework, java or antivírus (and others) are in the same version and configuration in both machines?
Best regards,

Gabriel Jesus
Occasional Contributor

RE: TestComplete and TestExecute performance problem

Do you have an equal amount of logs in the project on both machines? I've observed a massive hit in TC responsiveness, if too many logs are kept.
Occasional Contributor

RE: TestComplete and TestExecute performance problem

I've tried to run the same project on both machines without any history in logs. In my case it doesn't matter whether I have or not have any logs in project - the result is the same and massive delay in test execution is visible. Moreover on machine where problem doesn't occure more processes are running, including antivirus application and it works much faster. I will try to reinstall everything on this machine including OS and I let you know if it helps.
Regular Contributor

RE: TestComplete and TestExecute performance problem

You mention the physical machine configuration, but are you running TC in a VM on that machine, or directly on the physical host? If it's a VM are they clones of each other? How about their configuration? 1 or 2 VCPUS? How many hard disks and what kind?
Occasional Contributor

RE: TestComplete and TestExecute performance problem

Both environments are standing on physical machines (Windows and TC are installed on physical machines), so there is no virtualization. Disks are pretty fast in these machines. First machine uses SAS 450GB 15K, second machine uses SAS 146GB 15K.
Regular Contributor

RE: TestComplete and TestExecute performance problem

What about non-testcomplete benchmarks? Can you reproduce the performance issue outside of Test Complete at all?
New Here?
Join us and watch the welcome video:
Read the Latest News
NovemberNews
Top Kudoed Authors