cancel
Showing results for 
Search instead for 
Did you mean: 

Sometime TestComplete cannot find tested objects, which are recognized already

Highlighted
Contributor

Sometime TestComplete cannot find tested objects, which are recognized already

Hi,

      It seems the function of recognizing tested objects in TestComplete (7.50) is not stable…

 

For example, I have a script like this,


var webForm = Aliases["Sys_CSIS"]["IEXPLORE"]["pageCareComplaintForm"];


webForm["btnIsICYes"]["Click"]();

 


Most time, my script just works fine. But sometime just for no reason TestComplete cannot find the object. The error of “The Object doesn’t not exist.” Is logged.

 


After the failure, run the script again, it will be successful. The issue is hard to re-produce, but it happens time to time. It is very annoying. 

 


Thanks a lot!

 


Nancy


2 REPLIES 2
Highlighted
Staff

RE: Sometime TestComplete cannot find tested objects, which are recognized already

Hi Nancy,



Try obtaining the problematic object by using the WaitAliasChild method (see the "WaitAliasChild Method" help topic).

------
Yuri
TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Contributor

RE: Sometime TestComplete cannot find tested objects, which are recognized already

Hi, Jared,



     Yes, you are right. I use myWebForm["WaitAliasChild"]("myWebObject", 1000)["Exists"] to check if the web object exists, then click the button. So far it works fine.



      Thank you very much for your help!



Nancy
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors