cancel
Showing results for 
Search instead for 
Did you mean: 

Silverlight version 3 application

Highlighted
New Contributor

Silverlight version 3 application

Hi,



I have started automating a Silverlight application. I have configured TestComplete 7.5 so that it can interact with the Silverlight test objects as per the instructions in the Help Contents.


One of the test objects I am interacting with is a Grid (ClassName = RadGridView) (by Telerik). I am able to extract data, select a row, and edit the text of a cell.


I am editing the text of a cell by clicking on the cell and sending keys (using the test object's Keys method). However all the cells get lost


(disappear) in the Object Browser after I edit something in the Grid, and then when I replay the log reports that the 'objects do not exist'.


I have already tried to refresh the test objects even at the Sys level.


I tested this manually by viewing the Object Browser and then editing a cell, the same problem occurs (cells disappear).


I tested this using FireFox 3.5.5 and IE 6.0, the same problem for both browsers.


Is this a known issue with TestComplete? Any suggestions?



Thanks

Steve


1 REPLY 1
Highlighted

RE: Silverlight version 3 application

Hello Steve,




First of all, I recommend that you update your product to the latest version. TestComplete 7.52 is available for downloading from our web site and from the ClientServices portal (https://clientservices.automatedqa.com/).




If the issue still persists with the latest version of the product, please zip the entire project suite folder along with the test execution logs and send us the archive via the following web form:





Also, please attach screenshots of the Object Browser demonstrating the issue to your message.

--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors