cancel
Showing results for 
Search instead for 
Did you mean: 

Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*").Page("*")

Regular Contributor

Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*").Page("*")

I am trying to execute script in crossbrowsertesting.

My script execute and fail in early of execution, It's failing on below line of a function

Set page = Sys.Browser("*").Page("*")

while when i execute the same script normally without crossbrowsertesting. It's working fine

11 REPLIES 11
Highlighted
Staff

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

Just a quick thought 

could you try using aliases instead of the testcomplete Sys object?

so maybe something like: 

set page = Aliases.Browser("*").Page("*")

typically in the automation scripts, Aliases are more commonly used.

Best,
Justin Kim
Highlighted
Community Hero

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

OK...

 

1)  What's the error message as recorded in the log?

2) What's the rest of the code leading up to that line of code?

3) What OS/Browser combination are you using in CrossBrowserTesting?

 

There are a LOT of reasons for failing on that line and we could spend a lot of electronic bits flying back and forth explaining them all... but the more detail you can give us about the circumstances of the error, the easier it will be to get you an answer.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Highlighted
Regular Contributor

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

Hi @hkim5 @tristaanogre 

Please check attach screenshot for falied log details.

I am using windows 10, chrome 73 and resolution 1920*1080 in crossbrowsertesting

Highlighted
Community Hero

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

I need to see the code itself beyond the line you are indicating.

Generally speaking, though, based upon the messages....

1) Something in your code is trying to use Chrome in an environment where Chrome is not installed hence it's switching over to firefox.  If you intend to test your automation on multiple browsers, you need to make sure that you properly set up your code to be non-browser specific.

2) I see two different error message sets which indicates two different environments.... one in which Chrome is NOT installed and one on which it is.  To narrow down your problem, let's stick with one environment

3) The "chrome extension is not installed" error seems to be something you need to address with the CrossBrowserTesting people.  If an environment is being used by CrossBrowserTesting via TestComplete, the chrome extension needs to be present.  

4) With CrossBrowserTesting, because many of these environments are being spun up from cold start, there are things that need to load.  You're expecting the browser and the page to be immediately accessible in that line of code.  You should use more "Wait" functions.  Look up "WaitBrowser" and "WaitChild" and even the standard "Wait" function off of the page itself.  These methods make the code "smarter" when it comes to detecting when an object is available.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Highlighted
Regular Contributor

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

Hi @tristaanogre ,

Apologies, I did'nt share  full details beyond test logs.

Actually first I execute my script with chrome browser only where this kind of error come "not installed".

Then again i changed the browser to firefox and execute the script. so that's error come on firefox browser.

and today i execute my script on crossbrowsertesting cloud then found I need to install Intelligent quality extension

because I have 14.30(64 but) TC version and it's required 32 bit.

Really ?

 

 

Highlighted
Community Hero

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

you still haven't shared what I asked for... the actual code.

 

Note that you can't run a test coded for Chrome on a CrossBrowserTesting environment without Chrome installed.  So, it sounds, first of all, that you need to make sure that you're selecting appropriate environments for the tests your running.  Additionally, as mentioned above, you need to make sure you write your automation code to be browser agnostic. That way you can run it on any environment and not have to worry about "not installed" errors.

 

As for the intelligent quality add-on, it's only required if you need to use the feature.  But it's not something that is relevant to the original problem.  Browser recognition has nothing to do with that add-on.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Highlighted
Regular Contributor

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

Hi @tristaanogre 

Thanks for reply.

I want to inform you when I execute my script It was wotking fine on (Windows 10, Chrome73-64bit). Whole script execute fine and  generate report.

But when I am choosing (window 8, Or any other version of chrome, firefox)...not 64 bit then script is failed. Kindly check the failure in attachment.

 

Below is the code that i'm using.


Sub OpenBrowserWithURL (BrowserName,URL)
Dim firefox,InternetExplorer,Chrome,Edge
If (BrowserName="Firefox")Then
Browsers.Item(firefox).Navigate(URL)
Sys.Browser.BrowserWindow(0).Maximize
ElseIf (BrowserName="InternetExplorer")Then
Browsers.Item("iexplore", "11", Browsers.pX64).Run URL
Sys.Browser.BrowserWindow(0).Maximize
ElseIf (BrowserName="Edge")Then
Browsers.Item(btEdge).Navigate(URL)
Sys.Browser.BrowserWindow(0).Maximize
ElseIf (BrowserName="Chrome")Then
Browsers.Item(btChrome).Navigate(URL)
Sys.Browser("chrome").BrowserWindow(0).Maximize
Log.Checkpoint("Browser Name: "&BrowserName)
Log.Checkpoint("URL: "&URL)
End If
Browsers.Refresh
End Sub

Highlighted
Community Manager

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

Hi @kaiiii,

 

I see that you get the TestComplete Chrome Extension Is Not Installed or Is Disabled error message. First of all, you need to resolve it. You can find ways of how to do this here:

https://support.smartbear.com/testcomplete/docs/app-testing/web/messages/chrome-extension-is-not-ins...

 
---------
Tanya Gorbunova
SmartBear Community Manager

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!
Highlighted
Regular Contributor

Re: Script is getting fail in CrossbrowserTesting on first line Set page = Sys.Browser("*"

Hi @TanyaGorbunova 

Thanks for your reply.

I have already gone through this document and my script is working fine.

That chrome is not installed problem is occuring on crosbrowsertesting . When I am using different browsers version.

and I think We can not configure browsers setting overthere.

I am still looking for an answer.