Ask a Question

Problem in FireFox

gadic
Occasional Contributor

Problem in FireFox

Hi



I downloaded the trail version of TestComplete 8.70 and I am not able to do even simple flows like clicking on button in Firefox 9.



Please advice



Gadi
3 REPLIES 3
Julia_K
Staff

RE: Problem in FireFox

Hello Gadi,


Unfortunately, the information you gave us is not enough to help you. Could you please give us a bit more information on your issue?

Are you trying to test a web page shown in Firefox?

Is the test recorded successfully? Do any errors occur when you try to play back the test?

Could you please give us a step-by-step description of your actions?


Thank you.

I’m not a member of the SmartBear Support Team, I’m just helping users in this community.


Any views or opinions expressed do not necessarily represent those of SmartBear Software.
gadic
Occasional Contributor

RE: Problem in FireFox

I have recorded very simple flow with FF 9:



Navigation to http://html5demos.com/classlist and clicking on "big" button. The recored was very easy and it recognized "big" button".



When replaying it didn't recognize textnode as can be seen below:



There are several objects in the system that match the recognition attributes
of the "textnodeToggleclass"
mapped object.


This may cause the "Object not found" error.


Objects




Sys.Process("firefox").Page("http://html5demos.com/classlist").TextNode(3)


Sys.Process("firefox").Page("http://html5demos.com/classlist").TextNode("toggleClass")


Sys.Process("firefox").Page("http://html5demos.com/classlist").TextNode("classListTest")


Sys.Process("firefox").Page("http://html5demos.com/classlist").TextNode(2)


Sys.Process("firefox").Page("http://html5demos.com/classlist").TextNode(1)


Sys.Process("firefox").Page("http://html5demos.com/classlist").TextNode(0)



To solve the problem, you may need to modify mapping
settings for the "textnodeToggleclass"
object or one of its parent objects.


See Help for more
information



Julia_K
Staff

RE: Problem in FireFox

Gadi,


Thank you for the provided information.


The problem occurs, because the tested web page contains several objects that match the mapping criteria specified for the TextNode("toggleClass") object that holds your target button.

You need to modify the name mapping criteria for the textnodeToggleclass mapped object to make them unique. To learn how to do this, please see the Modifying Mapping Criteria Help topic.

Also, please go through the About the 'Ambiguous Recognition of the Tested Object' Message Help topic - it contains information on the "Ambiguous Recognition of the Tested Object" warning and gives several tips on resolving it.


Please let us know whether this helps or whether you have any additional questions.

Good luck with your testing.

I’m not a member of the SmartBear Support Team, I’m just helping users in this community.


Any views or opinions expressed do not necessarily represent those of SmartBear Software.
cancel
Showing results for 
Search instead for 
Did you mean: