cancel
Showing results for 
Search instead for 
Did you mean: 

Network Suite : Unable to Create User Session On Remote Computer

Highlighted
Contributor

Network Suite : Unable to Create User Session On Remote Computer

P.S : I have gone through all the Posts on this Forum related to Similar issue and Tried remedies. None of them worked for me 

 

HI , Can you please help me understand why I cant establish connection between Master and Slave Machine ? I am using Network Suite to execute test cases on remote machine.

Few Notables:
1. Master Machine is Physical Machine running Windows 7
2. Slave Machine is VM running Win Server 2012
3. I have access to both machine with my credentials
4. Master and Slave both has Test Complete 11 installed on it
5. Slave machine has no Firewall set up.
6. No Antivirus on Slave machine
7. Remote Settings on Slave machine
8. Restrict Remote Desktop Services users to a single Remote Desktop Services session = Enabled
9. Always prompt client for password upon connection = Disabled
10. Prompt for credentials on the client computer = Disabled

My Observations:
1. When I Setup a Host in Network Suite and Click on Base Path button, it does Load drives and folder from Slave Machine. I also observed, that I need to have Test Complete running on Slave machine in order to see Drives and folder in base path.
11. When Login mode = Automatic RDP Session and do “Verify Connection”, It immediately kicked out my Other RDP session ( I believe it is because we have single Remote Desktop Services session = Enabled ) . This means connection is at least hitting the machine. After some time following error message is displayed.

12. When I choose Login Mode = “Manual Connection” , It displays “User is not Logged in Message”

 

 

 


8 REPLIES 8
Community Manager

Re: Network Suite : Unable to Create User Session On Remote Computer

Hi Mspatel,

 

Thanks for the detailed description of the issue. I suppose that it can be related to your specific environment. I recommend that you refer this question to our TestComplete Support Team ( http://support.smartbear.com/product-list/ ) – they will assist you to set up connection between a master and slaves.

 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Contributor

Re: Network Suite : Unable to Create User Session On Remote Computer

We have the same setup, and we are experiencing the exact same issue.  However, instead of kicking off a single RDP session, the server disconnects ALL RDP sessions when trying to verify a host connection.  Can you post what the resolution was?

 

Thanks,

 

Danny Keton

Contributor

Re: Network Suite : Unable to Create User Session On Remote Computer

I havent talk to DEVSupport yet. I took different path and set up a physical Machine for Scheduled Run...I guess VM dont work very well with TC 


Occasional Contributor

Re: Network Suite : Unable to Create User Session On Remote Computer

Same issue here.  Was a solution ever provided?

Community Hero

Re: Network Suite : Unable to Create User Session On Remote Computer

Hi,

 

One thing to check: when you try manually connect to the remote machine using RDP, there *must not* be requested anything except user name and password. No Confidentiality Info or similair windows which are not handled by TestComplete.

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Occasional Contributor

Re: Network Suite : Unable to Create User Session On Remote Computer

Alex - Thanks for the information!  When I manually connect to the remote machine using RDP (nothing to do with TestComplete), there doesn't appear to be any screens other than username/password.

 

Here is a little more information about my issue (I sent this to support first.)

 

---------------

 

I’ve setup the Network Suite functionality on both the MASTER and SLAVE computers.  If I’m on the MASTER computer and connect to the SLAVE computer via remote desktop, then disconnect from the SLAVE using tscon, I am able to use the Network Suite to start the test runs on the MASTER.  This only works if the Network Suite > Hosts > Login Mode is set to MANUAL.

 

If the Network Suite > Hosts > Login Mode is set to AUTOMATED (RDP SESSION), I get this error:  “Unable to create a user session on the remote computer.”

 

I  believe I have every setting correct that’s listed on the “Configure Group Policies” page (https://support.smartbear.com/viewarticle/68479/#GPO).  I have also disabled the screensaver on the SLAVE.

 

I’m not sure what else to try.  Any suggestions?

Community Manager

Re: Network Suite : Unable to Create User Session On Remote Computer

Hi @csnider,

 

As far as I see you are working with Yuri from the Support Team to resolve this issue. Usually, the troubleshooting steps provided by Yuri help. It's sad to see that they didn't help you. It looks like your situation requires a deeper investigation. Please continue working with Yuri and share the solution you'll find.

 

For the future, let me post here the troubleshooting steps that may help community members to avoid getting the "Unable to create a user session on the remote computer." error:

  1. Disable UAC (see Disabling UAC Prompt [https://support.smartbear.com/testcomplete/docs/general-info/configuring/testing-under-admin-account...]) on the slave machine and try verifying the host.
  2. Can you confirm that the TestComplete version on the slave machine is the same as on the master machine? Please navigate to "Help | About" dialog to check this.
    Also, please navigate to "Help | Check for Updates" on the slave machine and make sure that there are no available updates (e.g. patches for Chrome) for TC. The uninstalled updates may prevent the successful host verification.
  3. Please make sure that all requirements are met (see Distributed Testing - Requirements [https://support.smartbear.com/testcomplete/docs/testing-with/advanced/distributed/requirements.html#...]). Especially, please pay attention to the settings which are specific to Windows 10 (see the attached screenshot). 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

Re: Network Suite : Unable to Create User Session On Remote Computer

Thanks Tanya!

New Here?
Join us and watch the welcome video:
Top Kudoed Authors