cancel
Showing results for 
Search instead for 
Did you mean: 

.Net Properties are not getting displayed in Object Browser

kashikar_harsh
Contributor

.Net Properties are not getting displayed in Object Browser

Hi,

  I am using TestComplete 7.52.678.7 to automate a Desktop application on Windows 7 machine. The problem is I want to use .Net properties of the obejcts, but I am unable to use them as they are unavailable. Also the Object browser is not displaying .Net Properties for any objects. While this is not the case when using Windows XP machine. Can anybody tell me if I am missing anything?



Thanks in advance



Regards,

Harshad
9 REPLIES 9
VitalyD
New Contributor

RE: .Net Properties are not getting displayed in Object Browser

Mb, .Net Framework 4.0 installed on machine with Windows 7???



If it's true - you must install special upgrade for TC 7.52 and install net framework 3.5 SP1

RE: .Net Properties are not getting displayed in Object Browser


Hi Harshad,





Vitaly is right. Currently, .NET framework v.4 is not supported. Installing this version of the framework can cause issues similar to yours. If this is the case, please contact us via the web form, and we'll provide you with a fix.
--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
kashikar_harsh
Contributor

RE: .Net Properties are not getting displayed in Object Browser

When dig more in this issue I found that the problem is that for different versions of AUT (Application Under Test) TestComplete recognizes the object differently. For e.g. If a particular object of AUT version 4.0 is recognized as Sys.abc the same object for AUT version 5.0 is recognized as Sys.pqr. In this case I'll have to create name mapping again for different versions of AUT. It is not the desired behavior.



The another problem that I am facing is, for the current version of AUT, TestComplete is unable to catch .Net Properties for any obejct. The Object browser does not display .Net properties section all together. But I want to use Accessibility propety to access MenuStrip and ToolStrip item of my AUT. As I could not found any other way to access them then making use of Click at the coordinates which I don't want to use. Is there any solution for this?

RE: .Net Properties are not getting displayed in Object Browser


Hi Harshad,







for different versions of AUT (Application Under Test) TestComplete recognizes the object differently







If the application's internals change from one version to another, the behavior you observe is expected. If the process name changes, TestComplete recognizes the application according to the current process name. To make sure that TC behaves correctly, please post here two screenshots: the first one demonstrating the Object Browser panel with the application's process visible in the object tree, and the second one demonstrating Task Manager's Processes tab with the application's process visible on the list of the running processes. 







TestComplete is unable to catch .Net Properties for any obejct







Please make sure that the ".NET Open Application Support" and ".NET Classes Support" plug-ins are installed (File | Install Extension). If this is not the case and the plug-ins are enabled, please let me know what version of the .NET framework is installed on your machine. You can verify this via the Programs and Features page. If .NET Framework v.4 is not on the list, try reinstalling the current framework.





If this does not help, please record a simple test over your application, play it back, zip the entire project suite folder and send us the archive. Also, please provide us with a screenshot demonstrating the Object Browser panel with the AUT's process node and all its child nodes expanded. In addition to that, please clarify the target controls' names, versions and vendors and describe what actions you need to perform over them. 
--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
kashikar_harsh
Contributor

RE: .Net Properties are not getting displayed in Object Browser

Hi David,

     Thanks for the reply. I cannot attached any snaps here as I cannot disclose the AUT. However for the second problem statement "Missing .Net properties" it is observed for simple "Notepad" application as well (Please find attached snapshot). I have made sure that .net framework 4.0 is not installed on my machine on which I am running AUT (it has .net framework 3.5 sp1) also the relevant .Net plugins are installed (Please refer dotnet_extensions_installed.jpg). Is the issue is with .Net framework 3.5 as well?



Regards,

Harshad
kashikar_harsh
Contributor

RE: .Net Properties are not getting displayed in Object Browser

May be the possibility with notepad is that it is not a .Net application and hence the .Net properties are not getting displayed. But it is not the case with my AUT. It is a .Net application. I have given e.g. and snaps of notepad just to give clear idea about my problem. Please let me know if there is any workaround for this.

RE: .Net Properties are not getting displayed in Object Browser


Hi Harshad,





The fact that your application is a .NET application, but there is no .NET section on the Object Browser's Properties pane, makes me suppose that your application is not recognized as open anymore. There can be several reasons for this. Installing .NET Framework 4 is one of the most common reasons - that is why, I asked you about it. 





First of all, we need to make sure that the issue persists for any .NET application. Please try to reproduce the problematic behavior with the Orders demo application. You can find the application in the "<TestComplete 7 Samples>\Open Apps\OrdersDemo\C#\bin\Debug\" folder. On Windows 7, Windows Vista and Windows Server 2008, TestComplete samples are located in the <Users>\Public\Documents\TestComplete 7 Samples folder. On other operating systems, the samples reside in the <Documents and Settings>\All Users\Documents\TestComplete 7 Samples folder. 





Do you see the .NET section for the Orders sample application? To help us investigate the situation, please create a new project, add the Orders demo application to the Tested Applications collection, record a sample script over the application, execute the script, zip the entire project suite folder and send us the archive.
--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
kashikar_harsh
Contributor

RE: .Net Properties are not getting displayed in Object Browser

Hi David,

          Installing .NET Framework 4 is one of the most common reasons



I have applied the fix patch for issue with .Net framework 4.0. So I guess now it should not be a problem with .Net framework version.



Do you see the .NET section for the Orders sample application?



Yes I could see the .NET section for the Orders sample application.



The problem that could seem relevant here is the point that you have made



The
fact that your application is a .NET application, but there is no .NET
section on the Object Browser's Properties pane, makes me suppose that
your application is not recognized as open anymore.




Is there any solution for this?



I want to use the .Net properties just to deal with MenuStrip and ToolStrip objects as they are not accessible by any other way. I have tried recording and playback but it makes use of coordinates to click the items which I do not want to do. So for now I have created a dll in c# for dealing with these controls and using it in the TestComplete. Thanks for providing such a wonderful functionality in TestComplete. But this is not the permanent solution.



Regards,

Harshad

RE: .Net Properties are not getting displayed in Object Browser


Hi Harshad,





As everything is fine with the Orders demo, .NET applications in general are open for TestComplete, so everything seems to be OK with the .NET Open Applications Support plug-in.





As far as I can see, you are already discussing the MenuStrip and ToolStrip objects issue with Alex here:

http://www.automatedqa.com/forums/forum/post.aspx?mode=singleThread&thread=177d362d-25fc-4b15-931b-2...







Do you still have some issues? If yes, please answer Alex's question regarding the control's name, version, and vendor.
--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Top Kudoed Authors