cancel
Showing results for 
Search instead for 
Did you mean: 

Member Not Found error when trying to set Value for a MSAA control

Occasional Contributor

Member Not Found error when trying to set Value for a MSAA control


I am using TestComplete 7.1 and trying to automate a Powerbuilder application. A lot of issues with setting values for the control are cropping up with both the New Mode using MSAA engine as well as the Compatibility mode using MSAAObjects.





New Mode

1. When using this, I am unable to set value for Edit controls(using "Text" property). TestComplete throws "Member Not Found" error when trying to do so. 

2. For DropDown controls I am unable to find any property/method to set value in the control.





Compatibility Mode
Again the "Member Not Found" error is thrown when using "Value" property to set the value for controls with role = "editable text" or role = "drop down"





This is very urgent. Can you please help me out.





Thanks,

V
2 REPLIES 2

RE: Member Not Found error when trying to set Value for a MSAA control

Hi Vaibhav,


The latest version of the product is TestComplete 7.52. I suggest that you use this version as several issues regarding MSAA have been fixed since TestComplete 7.10.


Please see our reply regarding working with PowerBuilder applications here.


As for the "Work with MSAA objects in mode compatible with TestComplete 6 and earlier" option, I suggest that you see the "Project Properties - MSAA Options" help topic for details. 


Also, in the future, please don't post duplicated requests (note that we reply to messages sent via the Contact Support form, AutomatedQA forums and the TestComplete section of the SQAforums site). This makes processing your requests much more difficult for us and does not increase the requests' priority anyway.



Best regards,
Alexey

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Occasional Contributor

RE: Member Not Found error when trying to set Value for a MSAA control

Allen, thanks for all your answers. 





I found that there is a DLL - PBACC100/105 which if registered in the host machine helps counter the error.





Installing powerbuilder helped identify objects in more depth.





Thanks again.





V
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors