cancel
Showing results for 
Search instead for 
Did you mean: 

Configure Browser Settings

SOLVED
Regular Contributor

Configure Browser Settings

Hi all

We recently had a new license for web browser testing.

We followed all the instructions word by word for as listed in the link below for setting up the browsers.

https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/index.htm...

Unfortunately, I am still unable to automate our web application using any of the browsers. TC is unable to identify any of the web object. We also have all the required plug-ins installed.

I thought of posting this in the forum before I could raise it with the support team. Any help is much appreciated. Please let me know if you need any further information.

 

Thanks

G

1 ACCEPTED SOLUTION

Accepted Solutions
Community Manager

Re: Configure Browser Settings

Hi Community,

Just want to post here the solution from the support team in case it may help you:

 

The problem with object recognition in the browser was solved by setting the "Use all processes" mode in the Process filter. You can find more information about it here:
https://support.smartbear.com/testcomplete/docs/working-with/managing-projects/properties/open-apps/...

 




---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

7 REPLIES 7
Community Hero

Re: Configure Browser Settings

Hi,

 

Just to be on the safe side: have you checked that version of your browser(s) is supported by your version of TestComplete?

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
Regular Contributor

Re: Configure Browser Settings

Hi

Please find details of browser version below for your reference:

 

TestComplete current version: 14.70.237.7 x64

Chrome Version 87.0.4280.66 (Official Build) (64-bit)

Firefox Current 78.3.1esr (64-bit)

Edge (chromium based) Version 87.0.664.47 (Official build) (64-bit)

 

Thanks,

Community Hero

Re: Configure Browser Settings

Hi,

 

As per https://support.smartbear.com/downloads/testcomplete/chrome-patches/, Chrome 87 is not supported by TC 14.70.

Firefox 78.3 seems to be supported (https://support.smartbear.com/downloads/testcomplete/firefox-patches/), but maybe 78.3.1 has some problems.

 

Try to upgrade to the latest TC 14.71 and check if it helps.

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
Regular Contributor

Re: Configure Browser Settings

Hi

 

I updated to latest version(14.71) still no luck.

 

Any other thoughts ?

 

Thanks

G

Community Hero

Re: Configure Browser Settings

Hi,

 

Any other thoughts ?

Unfortunately not at the moment, except contacting Support via the https://support.smartbear.com/message/?prod=TestComplete form.

 

P.S. Have you rebooted the box after TC upgrade? (I noted that from time to time when I do not reboot my box for a long time - several months - TC may stop to be able to recognize web page and child objects in the Object Browser.)

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
Regular Contributor

Re: Configure Browser Settings

Hi

 

Appreciate your time. Yes, I did rebooted the box.

 

Will raise it with support and post the outcome once its sorted.

 

Thanks

Community Manager

Re: Configure Browser Settings

Hi Community,

Just want to post here the solution from the support team in case it may help you:

 

The problem with object recognition in the browser was solved by setting the "Use all processes" mode in the Process filter. You can find more information about it here:
https://support.smartbear.com/testcomplete/docs/working-with/managing-projects/properties/open-apps/...

 




---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors