cancel
Showing results for 
Search instead for 
Did you mean: 

Chrome extension is enabled but testcomplete cannot detect it when recording new test

SOLVED
Highlighted
Regular Visitor

Chrome extension is enabled but testcomplete cannot detect it when recording new test

Hello,

 

I did an upgrade to the new Testcomplete 14.50 and now I'm unable to run tests on chrome however i have the extention enabled.

I tried to uninstall TestComplete and chrome than install and add the extention but it does not work !

Any idea please guys ?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: Chrome extension is enabled but testcomplete cannot detect it when recording new test

Hi @imen , I see that you are currently working on this with Support (#00445102). 

 

Let me post the advice they gave you here for whoever might be experiencing the same issue:

 

So, step one is to make sure the extension is set up like described in this article:  https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome-ex...

 

Step two, make sure the tcCrHost.exe process is running.

>>

Have you checked to make sure the tcCrHost.exe process is also running? This process is used to help TestComplete and the extension communicate with each other. If it is not running, TestComplete will not be able to identify objects in Chrome. To check if this is running:


1. Open the Task Manager.
2. Go to the Details tab.
3 The tcCrHost.exe should be running.

<<

 

 

Please share the results of your investigation with us when you solve this, thank you.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

1 REPLY 1
Highlighted
Community Manager

Re: Chrome extension is enabled but testcomplete cannot detect it when recording new test

Hi @imen , I see that you are currently working on this with Support (#00445102). 

 

Let me post the advice they gave you here for whoever might be experiencing the same issue:

 

So, step one is to make sure the extension is set up like described in this article:  https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome-ex...

 

Step two, make sure the tcCrHost.exe process is running.

>>

Have you checked to make sure the tcCrHost.exe process is also running? This process is used to help TestComplete and the extension communicate with each other. If it is not running, TestComplete will not be able to identify objects in Chrome. To check if this is running:


1. Open the Task Manager.
2. Go to the Details tab.
3 The tcCrHost.exe should be running.

<<

 

 

Please share the results of your investigation with us when you solve this, thank you.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors