cancel
Showing results for 
Search instead for 
Did you mean: 

Can't play, record a test and highlight an object

SOLVED
Highlighted
Occasional Contributor

Can't play, record a test and highlight an object

Hi everyone,

 

I automate UI tests for a web app with Chrome 80.

I can't play or record a test (i use keywordtest) because TestComplete seems to don't succeed to recognize objects. I try to start my test from the middle for example to see if it's not just the first object. But same problem.

The log says : "The window was destroyed during method execution."  and sometimes "Unable to find the object".

Then, i tried to use "drag the target to point to the object" but TestComplete highlight juste the entire webpage, not the object i point.

It's weird because I didn't change project properties and before this afternoon it works good.

 

Hope I'm clear.
If someone has an idea, it will be cool.

Thanks !

Mathias

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: Can't play, record a test and highlight an object

Hi @mathiasbsrt,

If the chrome extension is installed. You need to download the patch for chrome 80 from this link https://support.smartbear.com/downloads/testcomplete/chrome-patches/.

 

Hope it helps.

View solution in original post

11 REPLIES 11
Highlighted
Community Leader

Re: Can't play, record a test and highlight an object

check if patches for TC and chrome 80 installed, simply check in TC if any updates are available

Un sourire et ça repart

Highlighted
Occasional Contributor

Re: Can't play, record a test and highlight an object

Thanks for your answer. my test complete is up to date

Highlighted
Community Leader

Re: Can't play, record a test and highlight an object

is it TC 14.3 or 14.4 ?

Un sourire et ça repart

Highlighted
Occasional Contributor

Re: Can't play, record a test and highlight an object

It's TC 14.3

Highlighted
Community Leader

Re: Can't play, record a test and highlight an object

do you have the smartbear extension activated in Chrome ?

Un sourire et ça repart

Highlighted
Occasional Contributor

Re: Can't play, record a test and highlight an object

Yes, it is. 14.0 version.

 

This morning i retried to run my tests and it worked. During 1 hour i could point object (with red highlight).

but now, same problem than yesterday. It's very weird because i changed no parameters. I just record, use drag the tharget to point eh object tool, and run.

 

It's very anoying 😞

Highlighted
Community Leader

Re: Can't play, record a test and highlight an object

hmm thats strange, are you under any GPO ?
if you try with another browser is it the same ?

Un sourire et ça repart

Highlighted
Occasional Contributor

Re: Can't play, record a test and highlight an object

Yes, GPO of my company.

I tried to launch TestComplete as administrator but same problem.

Seems to be the same problem on firefox :When i try to point on an object, it higlight the web page but not my object. I point the object during 20seconds, and nothing happens except this red highlight on the entire web page

Highlighted
Contributor

Re: Can't play, record a test and highlight an object

Hi @mathiasbsrt,

If the chrome extension is installed. You need to download the patch for chrome 80 from this link https://support.smartbear.com/downloads/testcomplete/chrome-patches/.

 

Hope it helps.

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Join TechCorner Challenge!
Want a fun and easy way to learn TestComplete? Try solving weekly TechCorner challenges and get into the Leaderboard!

Challenge Status

How to execute remote test and obtain results via Test Runner REST API

Participate!

Comparing content of HTML table with Excel file data

Participate!

Compare HTML table with Excel file and correct data in the file

Participate!

Retrieve Data from a Web Page

Participate!
Top Kudoed Authors