cancel
Showing results for 
Search instead for 
Did you mean: 

Bug? Command prompt start with 7.52

han
Contributor

Bug? Command prompt start with 7.52

Has anyone else problem to use the command prompt to start 7.52?

Using: "C:\Program Files (x86)\Automated QA\TestComplete 7\Bin\TestComplete.exe" "Project.pjs" /r /e in Task Scheduler
8 REPLIES 8
Staff

RE: Bug? Command prompt start with 7.52

Hi,



Specify the full path to your project suite in this command, not just the file name.

------
Yuri
TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
han
Contributor

RE: Bug? Command prompt start with 7.52

Doing it - just made it shorter in this example - has been working in earlier releases.



The Testcomplete starts and I get the playback indicator but then nothing.

If I click the indicator - Windows reports "Testcomplete.exe is not responding"
Staff

RE: Bug? Command prompt start with 7.52

Hi,



What happens if you use the same command outside of Task Scheduler? Does the same problem occurs?

------
Yuri
TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
Occasional Contributor

RE: Bug? Command prompt start with 7.52

Hi,



I too am having problems with launching TestExecute from the Task Scheduler...



I'm trying to get it to launch TE & run my Project suite at System Startup but i'm getting inconsistencies...



I know that my command line works as I can force it to start from Task scheduler, but it doesn't always start when the system reboots...



any ideas?



many thanks in advance



KC



P.s. in your command line do you use /r /e  at the end,  if so make sure there are spaces inbetween eg...

"C:\Program Files\Automated QA\TestExecute 7\Bin\TestExecute.exe"

"D:\ProjectPath\Project.pjs" /r /e
Kay Chamberlain
Leica Microsystems Cambridge Ltd
Staff

RE: Bug? Command prompt start with 7.52

Hi,



Probably, your system is not loaded completely when TC is trying to start right after the rebooting. Anyway, it would help if you described the behavior you get in detail.

------
Yuri
TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
Occasional Contributor

RE: Bug? Command prompt start with 7.52

Hi,



The command line in the task scheduler is set to run Test Execute,



but when the system restarts following reboot there is no error message from Test Execute it just doesn't get launched.

If I check the Task manager the Test execute process does not exist...it hasnt started...

however tcrea is there...??



Its a Vista Machine, how can I get it to wait until the system has fully rebooted??  if this is indeed the issue?





Kay Chamberlain
Leica Microsystems Cambridge Ltd
Staff

RE: Bug? Command prompt start with 7.52

Hi,



Since TE doesn't actually start, the problem is related to Task Scheduler. It doesn't launch TE for some reason on the system start. As for tcrea, it is launched in another way (via standard Windows mechanisms that allow launching applications on the Windows logon).

------
Yuri
TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
Occasional Contributor

RE: Bug? Command prompt start with 7.52

got it sussed obvious really...



in task scheduler when you set it to trigger on system startup



there are advanced settings that are all greyed out unless you tick a check box, you can delay task for however long you need...3 minutes did the trick!



I think the label that says No additional settings required is a bit misleading but thats Microsoft for you!!



regards



K
Kay Chamberlain
Leica Microsystems Cambridge Ltd
New Here?
Join us and watch the welcome video:
Final Interview in the Series
API_testing_mistake#7
Top Kudoed Authors