cancel
Showing results for 
Search instead for 
Did you mean: 

Add existing item for keyword testing doesn't work.

sguda
Regular Contributor

RE: Add existing item for keyword testing doesn't work.

Hi David,



As i mentioned in the previous posts, another person added the LogIn_To_QAFA project to her project suite.



This project has 3 stepts, enter login id, Enter password and click on submit button.



She added this as an exixting item from the shared drive to her local drive under her project suite.



At first it opened the IE page but did not execute the steps.



Then i pointed the tested apps path to her machine c:\program files/internet explorer, then it executed the first 2 steps but not the clicking on submit button.



When i tried to highlight , it is not able to highlight.



Why is this happening. she has same browser version IE8 as mine.

is it a resolution problem or do i have to do anything else.



Please let me know. b'se we should be able to use each other's scripts.
sguda
Regular Contributor

RE: Add existing item for keyword testing doesn't work.

Also, if i have developed the script in IE8 version and if some body has IE7, The script doesn't work./

How can we make it work.
sguda
Regular Contributor

RE: Add existing item for keyword testing doesn't work.

Can anybody answer this so i can go a head.
AlexKaras
Community Hero

RE: Add existing item for keyword testing doesn't work.

Hi Sri,



IE7 and IE8 are quite different browsers.

I would recomment the following articles as a start up, hope, they will help:

http://www.automatedqa.com/blogs/post/09-12-10/cross-browser-testing-with-testcomplete/

http://www.automatedqa.com/blogs/post/09-12-03/web-testing-and-tabbed-browsers/
Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================

RE: Add existing item for keyword testing doesn't work.

Hi Sri,


I recommend that you refer to the Sharing Projects and Project Suites Among Several Testers article to learn how to organize teamwork.


As for using different browsers, tests recorded with IE 8 cannot run on IE 7 as is. To learn how to make your tests browser-independent, see the following SQAforums thread:

http://www.sqaforums.com/showflat.php?Cat=0&Number=568679


Best regards,
Alexey

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
sguda
Regular Contributor

RE: Add existing item for keyword testing doesn't work.

Hi,



1. I have the login script in one of my projects in the shared drive. Another person tried to add the Login keyword test as existing item. One thing i noticed is that We have to add the name mapping item of the original Login test also as existing item. Other wise simply adding the keyword test as existing item is not helping and executing the srcipt.



Is that right? 



2. Also when another person added the script like that, it was not clicking on submit button as it is not mapping correctly on her machine. The IE version is 8 on both of our machines.

One thing i saw was the tabs and icons are not displaying properly , they are overlapping on to other tabs and when i highlight the objects when she recorded also it is not highlighing where the login text is or where the submit button is . it is highlighting little above to the actual submit tab. this is even when she recorded in her machine.



Any idea why this is happening? What can we do to solve this problem.

RE: Add existing item for keyword testing doesn't work.


Hi Sri,





I have the login script in one of my projects in the shared drive.






We strongly recommend that you avoid adding project items from a shared network drive. To organize your teamwork, you need to open your project in the networked mode. 





Working in the networked mode allows several testers to get access to the same project, but have their own project-related settings. Also, working in this way, you can update the project without any confusion related to multiple copying, pasting, and relinking plenty of project items.





I recommend that you organize your work in a way described in the Sharing Projects and Project Suites Among Several Testers article.









it is highlighting little above to the actual submit tab






Please make sure that the page's zoom ratio is set to 100%. TestComplete does not support other zoom ratios. See the "Setting the Page’s Zoom Ratio" section of the "Preparing Web Browser" article for details.





If the zoom ratio is set to 100%, but you still face the issue, please provide us with a video demonstrating the behavior. For example, you can use Jing, which is a free recorder. Also, please zip the entire project suite folder and send us the archive along with the recorded video. 
--
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
sguda
Regular Contributor

RE: Add existing item for keyword testing doesn't work.

Thank you so much, the zoom setting worked.
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors