cancel
Showing results for 
Search instead for 
Did you mean: 

Add Table failing to extract data

SOLVED
AndyG
Occasional Contributor

Add Table failing to extract data

Hello all,

I am attempting add a table through Stores > Tables > Add Table dialog to that I can do a table compare at a certain point in my test.

I have copied and pasted the MappedObject into the Add Table dialogs 'Object' field.  When I do that, the dialog temporarily disappears and then returns with a preview of the table in question, all good so far.

When I click 'Next', I get a message stating:
"We are unable to extract data because this table is not recognized."

The table in question is a little complicated, so I tried the same thing with the most basic of tables.  Again I get a preview, but then get the same message as above.

I am using the latest version 14.72.408.7 x64.

Has anyone else experienced this?

1 ACCEPTED SOLUTION

Accepted Solutions
AlexKaras
Community Hero

Re: Add Table failing to extract data

Hi,

 

I am using the latest version 14.72.408.7 x64.

Actually, current latest version is 14.72.485 though I don't think this would make a difference.

As no one here can provide you with any piece of advice I would ask Support via the https://support.smartbear.com/testcomplete/message/ form.

 

The approach that you described in your initial post is a valid one and can be used if your test is working with the same static data. IIRIC, Web Table checkpoint stores data snapshot when created and then just does a plain compare of the saved data against the actual current table data.

Personally I don't like the approach when tests are executed over static data (restored/re-generated before every test run), but prefer to have test code that can take any data that already exist and use/work with them. Web Table checkpoint cannot work with dynamic data and this is the reason of why I don't use (practically) any data checkpoint provided by TestComplete.

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================

View solution in original post

7 REPLIES 7
sonya_m
Community Manager

Re: Add Table failing to extract data

Thank you for starting this thread AndyG!

 

Has anyone faced anything similar? Any ideas why the table isn't recognized? Your help is very much appreciated🙂

@Wamboo @tphillips @Marsha_R @BenoitB  


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
BenoitB
Community Hero

Re: Add Table failing to extract data

@sonya_m  Sorry did not use name mapping at all 😞

Un sourire et ça repart

Marsha_R
Community Hero

Re: Add Table failing to extract data

I haven't used Tables but maybe @AlexKaras has?

AlexKaras
Community Hero

Re: Add Table failing to extract data

maybe @AlexKaras has?

Neither did I.

Table checkpoints are static and thus were always barely usable for me.

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
AndyG
Occasional Contributor

Re: Add Table failing to extract data

Being new to TC, perhaps I am unaware of the best way to test an html table against some expected results.  I thought perhaps the way described in my opening post was the way to do it.....

Is there any other feature of TC that can do this without resorting to coding that you know of?
https://support.smartbear.com/testcomplete/docs/app-testing/web/general/examples/parsing-html-tables...

Thanks.

AlexKaras
Community Hero

Re: Add Table failing to extract data

Hi,

 

I am using the latest version 14.72.408.7 x64.

Actually, current latest version is 14.72.485 though I don't think this would make a difference.

As no one here can provide you with any piece of advice I would ask Support via the https://support.smartbear.com/testcomplete/message/ form.

 

The approach that you described in your initial post is a valid one and can be used if your test is working with the same static data. IIRIC, Web Table checkpoint stores data snapshot when created and then just does a plain compare of the saved data against the actual current table data.

Personally I don't like the approach when tests are executed over static data (restored/re-generated before every test run), but prefer to have test code that can take any data that already exist and use/work with them. Web Table checkpoint cannot work with dynamic data and this is the reason of why I don't use (practically) any data checkpoint provided by TestComplete.

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================

View solution in original post

AndyG
Occasional Contributor

Re: Add Table failing to extract data

Thanks for the reply Alex.

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors