cancel
Showing results for 
Search instead for 
Did you mean: 

WaitWinFormsObject no longer working with wildcards?

Highlighted
Contributor

WaitWinFormsObject no longer working with wildcards?

I have a set of tests that use WaitWinFormsObject quite often to wait for specific forms to appear.  All the forms are DevExpress XtraForm subclasses.  Some of them use wildcards for the in the type, caption, or both.  All the ones using wildcards have stopped working. Is there a setting somewhere now that toggles wildcards on/off?  Or has something else changed?  These tests were migrated from v12 and used to work without any problems, so perhaps there's something that needs to be changed in the calls to WaitWinFormsObject that isn't stated in the documentation for the method?  Or is it a problem that was introduced by DevExpress (the applications used to use DevExpress 16.x, but are currently on 18.x.  They don't often see a lot of work on them, so they've not yet been upgraded to v20).

3 REPLIES 3
Highlighted
Community Hero

Re: WaitWinFormsObject no longer working with wildcards?

What version of TC are you using now?

Highlighted
Contributor

Re: WaitWinFormsObject no longer working with wildcards?

I'm running them in 14.7.  I happened upon a page that indicates TestComplete now only supports specific versions of DevExpress controls and the version these applications use is 18.2.6, which falls between the 18.1.3 and 19.something versions that the page says will work with TC.

Highlighted
Community Hero

Re: WaitWinFormsObject no longer working with wildcards?

https://support.smartbear.com/testcomplete/docs/general-info/supported-technologies/controls/devexpr...

 

Yes, it looks to me like your Dev Express version is not supported.  You should ask Support about this.  Here's their link.

https://support.smartbear.com/message/?prod=TestComplete

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors