cancel
Showing results for 
Search instead for 
Did you mean: 

The parent object was not found: NameMapping.​Sys While running the scripts in different machien

Highlighted
Occasional Contributor

The parent object was not found: NameMapping.​Sys While running the scripts in different machien

My automation scripts working fine in the machine where the name mapping is Done.But the same fails in all other machines.Its because the sys object properties are different in other machine. How can resolve this issue?.Please fidn the screen shot after importing the scripts in new machines. Sys properties become blank

smithanair_0-1603946237031.png

 

3 REPLIES 3
Highlighted
Community Leader

Re: The parent object was not found: NameMapping.​Sys While running the scripts in different machie

Hi, use NameMapping condition:

 

https://support.smartbear.com/testcomplete/docs/testing-with/object-identification/name-mapping/cond...

 

make a: OR, AND condition for differnet values of that object.

Highlighted
Occasional Contributor

Re: The parent object was not found: NameMapping.​Sys While running the scripts in different machie

Name mapping condition i have already tried. But its failing because the sys is not available. Please find the screen shot below

smithanair_0-1603961265460.png

 

Highlighted
Community Manager

Re: The parent object was not found: NameMapping.​Sys While running the scripts in different machie

Thank you Wamboo!

 

Hi @smithanair, I found a couple of threads that might help:

 

https://community.smartbear.com/t5/TestComplete-Desktop-Testing/The-object-quot-Sys-quot-does-not-ex...

https://community.smartbear.com/t5/TestComplete-Desktop-Testing/The-object-quot-Sys-quot-does-not-ex...

 


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors