cancel
Showing results for 
Search instead for 
Did you mean: 

The TCHookX86.exe process has not responded for 5000 ms

SOLVED
Highlighted
Occasional Contributor

The TCHookX86.exe process has not responded for 5000 ms

Hi all,   I have a machine that I am trying to install Test Complete 14.20 on.   It will not run in x64 mode.  I get the following error:

 

Either the installation files or registry data are corrupted or not accessible. Reason: The TCHookX86.exe process has not responded for 5000 ms.
The application will be shut down.

 

TC will run if I launch the x86 mode but not x64  

 

More Info:

I have 2 Machines.  I installed Test Complete and Test Execute 14.20 with no problems on a new machine Win 10 enterprise 1903.  It works fine.  

I have another machine that had wiped and reinstalled the OS.   Win 10 Enterprise 1903.  Both machines are setup and on a domain that is managed by IT.  It will not run in x64.  I installed in the default location. 

 

After I got the error the first time, I uninstalled the product.  I went and found every folder related to smart bear and deleted them.    I have reinstalled this twice.   Still the same error.      Before I wiped the OS, I had TC 12 on the machine and it ran no problem.  Anyone else having this issue?  What are my next steps?   Any log files besides event viewer that  I can look at?

 

Event viewer:

The description for Event ID 0 from source TestComplete cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Either the installation files or registry data are corrupted or not accessible. Reason: The TCHookX86.exe process has not responded for 5000 ms.
The application will be shut down.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Occasional Contributor

(Solved) Re: The TCHookX86.exe process has not responded for 5000 ms

@TanyaGorbunova 

@tristaanogre 

 

Support help me get up an running.  The issue was the process did not have enough time to start on my machine.  I had to increase the wait period.  Not sure what the bottleneck is when I try to start TC.  My computer is a Dell T7600 with with 2x Xeon Processors and 32 gb of RAM. 

......................................

Anyway here are the steps if anyone has the issue. 

 

When starting TestComplete, you may get the The TCHookX86.exe process either does not respond or does not exist errors. Usually, these errors occur on machines which do not have enough system resources.

The error is caused by a delay that occurs during the communication of TestComplete.exe and the hook processes that attach themselves to applications running on your machine. There is an auto-timeout value that can be changed to give the hook processes more time to "get ready" with the TestComplete application. Those values can be found in your registry at these locations:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SmartBear\TestComplete\14.0]
"TCHookX86NormalModeWaitTimeout" - set 10 (0000000a in hex)
"TCHookX86SilentModeWaitTimeout" - set 60 (0000003c in hex)

 

(I had to create ....SmartBear\TestComplete\14.0)
[HKEY_LOCAL_MACHINE\SOFTWARE\SmartBear\TestComplete\14.0]
"TCHookX86NormalModeWaitTimeout" - set 10 (0000000a in hex)
"TCHookX86SilentModeWaitTimeout" - set 60 (0000003c in hex)

Please note that the values may not exist in the registry on your machine. You may have to add these dword values into the registry key. Note that the values are in the hex numerical format. It makes sense to double the current values as a preliminary step and work upward until you would find a value that works.

Note: remember to always back up your registry before modifying it, just in case.

View solution in original post

8 REPLIES 8
Community Hero

Re: The TCHookX86.exe process has not responded for 5000 ms

I've seen, in recent posts, that there are some aggressive malware scanners out there that may interfere with that process.  You might want to try two things.

 

1) Run TestComplete/TestExecute as an administrator

2) Disable or update your malware scanner to ignore TCHookx86.exe


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Extensions available
Occasional Contributor

Re: The TCHookX86.exe process has not responded for 5000 ms

Thanks, I will whitelist in Windows Defender.   I think IT has a program on our machines called crowdstrike, but we have no access to it.  It interesting that none of the other machine are having this issue.  Only this one. 

Community Manager

Re: The TCHookX86.exe process has not responded for 5000 ms

Hi @stampy986,

 

Have you managed to resolve the issue finally?

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Join the annual community event and share your stories to win gifts
Wintertainment2019
Occasional Contributor

Re: The TCHookX86.exe process has not responded for 5000 ms

Not yet, I am waiting on IT to take a look at my machine to see if the antivirus is causing the problem. There are no notification on my machine that anything is being blocked.   I am not sure what kinda of antivirus programs IT is monitoring with.    Interesting though, I found a temporary workaround by logging out or restarting my computer.  When I log back in, I can immediately lauch TC and have no problems.  If i wait too long I cant launch it.   

 

Community Manager

Re: The TCHookX86.exe process has not responded for 5000 ms

Thanks for the update, @stampy986.

 

Please share with us if the IT team finds something. In the meantime, I can suggest that you go through the following article. Perhaps, it may help improve the performance:

Enhancing TestComplete Performance 

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Join the annual community event and share your stories to win gifts
Wintertainment2019
Occasional Contributor

Re: The TCHookX86.exe process has not responded for 5000 ms

No solution yet.   Our antivirus does not appear to be blocking it.   Is there and log or dump file I can look at that may give me another reason?   The windows event logger doesnt help and only shows the same message test complete gives.

Community Manager

Re: The TCHookX86.exe process has not responded for 5000 ms

Hi @stampy986,

 

Sad to hear this. Could you please submit a case to our Support Team to investigate this issue deeper?

https://support.smartbear.com/message/?prod=testcomplete

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Join the annual community event and share your stories to win gifts
Wintertainment2019
Occasional Contributor

(Solved) Re: The TCHookX86.exe process has not responded for 5000 ms

@TanyaGorbunova 

@tristaanogre 

 

Support help me get up an running.  The issue was the process did not have enough time to start on my machine.  I had to increase the wait period.  Not sure what the bottleneck is when I try to start TC.  My computer is a Dell T7600 with with 2x Xeon Processors and 32 gb of RAM. 

......................................

Anyway here are the steps if anyone has the issue. 

 

When starting TestComplete, you may get the The TCHookX86.exe process either does not respond or does not exist errors. Usually, these errors occur on machines which do not have enough system resources.

The error is caused by a delay that occurs during the communication of TestComplete.exe and the hook processes that attach themselves to applications running on your machine. There is an auto-timeout value that can be changed to give the hook processes more time to "get ready" with the TestComplete application. Those values can be found in your registry at these locations:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SmartBear\TestComplete\14.0]
"TCHookX86NormalModeWaitTimeout" - set 10 (0000000a in hex)
"TCHookX86SilentModeWaitTimeout" - set 60 (0000003c in hex)

 

(I had to create ....SmartBear\TestComplete\14.0)
[HKEY_LOCAL_MACHINE\SOFTWARE\SmartBear\TestComplete\14.0]
"TCHookX86NormalModeWaitTimeout" - set 10 (0000000a in hex)
"TCHookX86SilentModeWaitTimeout" - set 60 (0000003c in hex)

Please note that the values may not exist in the registry on your machine. You may have to add these dword values into the registry key. Note that the values are in the hex numerical format. It makes sense to double the current values as a preliminary step and work upward until you would find a value that works.

Note: remember to always back up your registry before modifying it, just in case.

View solution in original post