cancel
Showing results for 
Search instead for 
Did you mean: 

Tests for InstallShield wizard stopped working

SOLVED
Highlighted
Contributor

Tests for InstallShield wizard stopped working

Hello,

 

I’m having a problem with InstallShield wizard.  I have been using this in tests which have been running fine for over two years to uninstall and install versions of the desk top application to be tested.

 

The test scripts have stopped working as they no longer recognise the controls in the InstallShield wizard, the Modify, Repair, Remove options and the Next button etc.

I have tried recording a fresh test script to check if my old scripts have a problem, but when I run the script just recorded it has the same issue: not recognising any of the controls in the InstallShield wizard.

I thought I might have somehow messed up the name mappings, so I tried writing a script from scratch using the name mappings I had for the wizard… again, none of the controls were recognised.

I then tried deleting the name mappings and setting them up fresh…  again, none of the controls were recognised.

 

Does anyone have an idea how I might try fixing this?

 

Thanks in advance,

 

Dan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: Tests for InstallShield wizard stopped working

It sounds like InstallShield has changed something.  

 

Does Object Spy show you any details in the InstallShield box?

View solution in original post

2 REPLIES 2
Highlighted
Community Hero

Re: Tests for InstallShield wizard stopped working

It sounds like InstallShield has changed something.  

 

Does Object Spy show you any details in the InstallShield box?

View solution in original post

Highlighted
Contributor

Re: Tests for InstallShield wizard stopped working

Hi Marsha,

 

I'm off for the day now.  I'll have a look tomorrow.

 

Thanks

 

Dan

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors