cancel
Showing results for 
Search instead for 
Did you mean: 

Sys.Process("rundll32") is not shown in object browser

SOLVED
Frequent Contributor

Re: Sys.Process("rundll32") is not shown in object browser

Hi Robert,

 

Object Browser shows only one running process of Sys.Process("rundll32") and I am making action (Like Clicking) on the correct dialog. Even TestComplete Log shows it performed the action correctly. It dint throw any ambiguos object recognition error message too.

 

Please see the below image

ErrorLog.pngObjectBrowser.png

 

Even after clicking the button, the dialog remains same on the screen. But when I do manual click on No button, the dialog disappears. Expected the same behavior while running through TestComplete.

 

Thanks,

Karthik K R

Community Hero

Re: Sys.Process("rundll32") is not shown in object browser

Is there more than one instance of WIndow('#32770')?  That could also be part of the issue.

 

Also... could be timing... while the window may be up and clicked on, there may be something else going on where the click is not recognized, some sort of background processing temporarily disabling the button.  Have you tried, just for debugging purposes, putting a hard coded delay before the button click?


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Extensions available
Frequent Contributor

Re: Sys.Process("rundll32") is not shown in object browser

I have verified that only one instance of window("#32770") appears in the object browser. Also I have tried giving some hard coded delays, unfortunately this too didnt work.

 

Thanks,

Karthik K R

Frequent Contributor

Re: Sys.Process("rundll32") is not shown in object browser

All, 

 

I have upgraded my TestComplete version from 12.0 to 14.0, and with the latest version I am able to click on the buttons successfully and the dialog disappears.

 

I am really not sure what was the problem with TC 12.0, luckily TC 14.0 helped me out of the problem.

 

Thanks,

Karthik K R

New Here?
Join us and watch the welcome video:
Top Kudoed Authors
Join the September Hub-bub to show off, learn and win