cancel
Showing results for 
Search instead for 
Did you mean: 

Stores Tables - cell shows blank when replacing text in the editor

Occasional Contributor

Stores Tables - cell shows blank when replacing text in the editor

I want to update 3 cells in a Table in the Stores collection. To edit a cell I open the Table Editor, click in the cell which highlights the text, hit delete to clear the text, then paste in the new text and hit Enter.

This works fine in two of the three cells, but for reasons I can't figure out, one of the cells shows blank after I copy the new text and hit Enter. I can click in the apparently blank cell, type, and only see the cursor move, none of the text I'm typing shows.

I'm wondering if it is a length issue because this value is much longer than the other two values that I'm editing, but I can't find documentation on this. The value that I'm deleting isn't any shorter than the new text, but it is broken up into lines, whereas the replacement value contains all the text on a single line.

Any thoughts?

Thanks in advance!

10 REPLIES 10
Occasional Contributor

Re: Stores Tables - cell shows blank when replacing text in the editor

I saved the blank row, ran the script, and the table checkpoint gave me the results I expected. So apparently TestComplete can see the value in the field, but I still can't.

Community Manager

Re: Stores Tables - cell shows blank when replacing text in the editor

Community, is there anything we can help here?

 

@Marsha_R@RUDOLF_BOTHMA@AlexKaras ?

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Community Leader

Re: Stores Tables - cell shows blank when replacing text in the editor

Full disclosure : I have no idea, I'm just guessing before assuming its an obscure TC bug.  I would see if I can check in some way if the data type is interpreted incorrectly.  Eg the original value is a string, the new value is interpreted as an int.  Out of curiosity  does taking the string you want to add and pasting it into notepad, then pasting it from notepad into the table make any difference ?  It might be there's some formatting that TC picks up that will get stripped out when you put it into plain old notepad first ?  Or, take the original value, paste it into notepad, edit only one character - alphabet, not number - and paste back.  Does it work now ?  Same goes for just pasting out and back in the original value to see if TC displays it differently, since we can't be sure if it's the original or the new value that is actually the culprit.


-------------------------------------------------
Standard syntax disclaimers apply
Regards,
Community Manager

Re: Stores Tables - cell shows blank when replacing text in the editor

Thanks for the reply, Rudolf. I appreciate it.

 

@mboyce, also, you can reach out to our TestComplete Support Team to investigate this question. You can contact them here: https://support.smartbear.com/message/?prod=TestComplete

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

Re: Stores Tables - cell shows blank when replacing text in the editor

Thanks for the replies. I am working with Support to figure this out, although so far they can't recreate it.

 

If I simply edit the cell by changing one letter, I have no problem. I can see the copied text in the cell. Everything's fine.

 

But what I need to do is change multiple lines of text into one line (ie remove pretty print). Of the three cells I'm editing in this way, only one has an issue. It also happens to be the longest of the three, which is why I assumed a length limit.

 

I'm unsure how the cell was originally created, and I can't simply click "Update the table checkpoint" from the log when the checkpoint fails because the tested app has an exisiting issue that requires manually editing the cells to be correct. 

Community Hero

Re: Stores Tables - cell shows blank when replacing text in the editor

Hi,

 

While it is obviously on your own risk, but as a workaround you may try to open the proper disk file from the Stores in the editor (it should be an XML file with some other extension, don't forget to make a copy) and check if you can edit it directly.

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Community Hero

Re: Stores Tables - cell shows blank when replacing text in the editor

I would try putting that long value in the first cell and see if it shows up.

Highlighted
Occasional Contributor

Re: Stores Tables - cell shows blank when replacing text in the editor

@AlexKaras Thanks for the suggestion! I opened the table file (Stores/Tables/tableName.tcTbl) in notepad++, which is an xml, but the table data itself is not readable.

Occasional Contributor

Re: Stores Tables - cell shows blank when replacing text in the editor

@Marsha_R Thanks for the suggestion! Putting the long value in the first cell has the same result. It appears blank.

 

I'm assuming there's something about the content I'm inserting that isn't playing nicely with the table. The string I'm inserting is in xml format.

New Here?
Join us and watch the welcome video:
API Testing Mistake #2
APITestingMistake#2
Top Kudoed Authors