cancel
Showing results for 
Search instead for 
Did you mean: 

Message - Unable to send the results of the "Function" test to an external test management system.

SOLVED
siddesh
Occasional Visitor

Message - Unable to send the results of the "Function" test to an external test management system.

After updating to TC  14.74.437.7 version, I am not able to run the functions which are associated with Azure DevOps test plan , if i remove the Association the test will run normally . 

TC ERR.png

1 ACCEPTED SOLUTION

Accepted Solutions
sonya_m
Community Manager

Re: Message - Unable to send the results of the "Function" test to an external test manage

Let me quote the Support Team for anyone experiencing the same issue:

 

>>

This is a known issue with 14.74. This version erroneously stores the linked Case ID in the tmsData attribute of linked Test Items (see your project's .mds file). Clear this attribute so the tests run normally again (tmsData="").

 

Note that it does not affect the linking feature as in this case, Azure itself stores the linking data, and TestComplete is supposed to just pull it via Azure API.

<<

 

Please contact Support for a patch to help overcome this!


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

6 REPLIES 6
Marsha_R
Community Hero

Re: Message - Unable to send the results of the "Function" test to an external test manage

Did this association to Azure DevOps work properly before you updated TC?  If so, I suggest that you contact Support directly.  Here's the link:

https://support.smartbear.com/testcomplete/message

simonaferrara
Contributor

Re: Message - Unable to send the results of the "Function" test to an external test manage

@Marsha_R @siddesh do you have any news about this issue?

 

I've got the same issue after I've updated Test Complete version to the 14.74.437.7 .

 

This error was not generated with the previous version that I had got (14.72.408.7).

 

Note: the error is generated only for the test items that have been associated to a test case after the Test Complete version update.

 

I've tried to remove the association with the test case, for the test items, and then add it. But there is still this error.

 

Do you have some news from support? What can be done? Now the test results are Failed because of this error, and it gives us a false information, because it should be Passed.

 

Thanks.

Simona

 

Marsha_R
Community Hero

Re: Message - Unable to send the results of the "Function" test to an external test manage

@simonaferrara We're just volunteers helping on the forums and we don't have contact with Support.  Use the link I posted earlier to contact Support with your question directly and they will help you out.

simonaferrara
Contributor

Re: Message - Unable to send the results of the "Function" test to an external test manage

Ok @Marsha_R , I was asking within this post to understand if a solution had been already given to @siddesh , because it is the same of my issue.

So I could prevent to open a request to the support if it had been already solved.

Now, I surely open directly a ticket to the support by myself, as suggested to siddesh.

sonya_m
Community Manager

Re: Message - Unable to send the results of the "Function" test to an external test manage

Just an update, @siddesh  I found your ticket with Support and see that our team is still waiting for info from you. Please keep working with them.

@siddesh / @simonaferrara, please post a solution here when you get one, this could help community members  facing a similar situation a lot 🙂


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
sonya_m
Community Manager

Re: Message - Unable to send the results of the "Function" test to an external test manage

Let me quote the Support Team for anyone experiencing the same issue:

 

>>

This is a known issue with 14.74. This version erroneously stores the linked Case ID in the tmsData attribute of linked Test Items (see your project's .mds file). Clear this attribute so the tests run normally again (tmsData="").

 

Note that it does not affect the linking feature as in this case, Azure itself stores the linking data, and TestComplete is supposed to just pull it via Azure API.

<<

 

Please contact Support for a patch to help overcome this!


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors