cancel
Showing results for 
Search instead for 
Did you mean: 

Item Invisible

Frequent Contributor

Item Invisible

Hi all

I experienced this odd behaviour and I was wondering how this can be sorted or if there is any workaround at all.

 

image.png

image.png

image.png

image.png

 

The above ListBox36 test has worked perfectly fine everytime in the past until today when it failed with reason 'the list box is invisible and thus cannot be activated'.

Basically ListBox36 is the dropdown list (image above in yellow) and I can see my automation script opening the dropdown, so I investigated this further.

An interesting thing came to light is that the Alias here (ListBox36) in name mapping does not contain the original child items from the dropdown list. So when I used object spy on the same dropdown again (ie: start month) it shows completely a different Alias (ListBox17). Moreover this new Alias(ListBox17) is an existing alias to a different object.

So, to me it seesm that the alias are being swapped over however their child items isn't Cat Frustrated

 

Can someone please help/advise to understand the below and suggest potential solution to sort this out :

1. How and why the original alias is automatically renamed to a different alias ?

2. What can I do to avoid this random changing of alias in near future so my test doesn't fail ?

 

Thanks in advance.

 

2 REPLIES 2
Frequent Contributor

Re: Item Invisible

Request you to add the Object browser & NameMapping screenshot. 

 

 

Few generic comments. 

Add NameMapping Manually. Don't use more skips while adding NameMapping.

Using UIA object - Verify whether the class name is added to the Open applications.

Check for the properties that is added. Try to use unique property.

Try using descriptive programming.

Use debugged to check the changes in object. 

uncheck auto update namemapping during execution.
With Regards
Vallalarasu Pandiyan | LinkedIn |Vallalarasu.p@gmail.com
Frequent Contributor

Re: Item Invisible

Thanks for replyin @Vallalarasu_P 

 

Re your generic coments, I think most of the stuff is in place and followed

I shall share the screenshot shortly.

 

What I would like to understand is that what's causing the alias to change here ? If most of the aliases keep changing this way then the script wouldn't be very reliable and cause lots of maintenance. How do we avoid this ? Thanks