cancel
Showing results for 
Search instead for 
Did you mean: 

I updated my testcomplete from version 12 to 14 now it does not recognize the mapping of my screen

SOLVED
paulohg6
Occasional Contributor

I updated my testcomplete from version 12 to 14 now it does not recognize the mapping of my screen

My procedure In TC 14:

 

procedure abriRotina(rotina:string);
begin
Sys.Process('PCINF000').Window('TfrmPrincipal').Window('TEdit', '', 3).Keys(rotina+'[Enter]');
end;

My Procedure in TC 12 

procedure abriRotina(rotina:string);
begin
Sys.Process('PCINF000').VCLObject('frmPrincipal').VCLObject('edtCodigoRotina').Keys(rotina+'[Enter]');
end;

This code are in Flat mode.

I need too remap all my  tests???? How to replace the Window to VLOBject?

How can i get the same map object of testcomplete 12 in 14???

1 ACCEPTED SOLUTION

Accepted Solutions
tristaanogre
Community Hero

Re: I updated my testcomplete from version 12 to 14 now it does not recognize the mapping of my scre

What language is your application undertest written in?  Delphi?  C++?  You may need to make some adjustments to recognize the application as open.  Also, go to File | Install Extensions and make sure that the Desktop option has all sub options checked.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

3 REPLIES 3
tristaanogre
Community Hero

Re: I updated my testcomplete from version 12 to 14 now it does not recognize the mapping of my scre

What language is your application undertest written in?  Delphi?  C++?  You may need to make some adjustments to recognize the application as open.  Also, go to File | Install Extensions and make sure that the Desktop option has all sub options checked.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

paulohg6
Occasional Contributor

Re: I updated my testcomplete from version 12 to 14 now it does not recognize the mapping of my scre

Thanks!!!!! 

EnergizerBunny
Contributor

Re: I updated my testcomplete from version 12 to 14 now it does not recognize the mapping of my scre

I have seen this for years since version 9. If you search on these forums you will find simular observations going back years.

I consider it a bug in TestComplete and have code to handle it. We don't use name mapping because of this.

Here is what I have found that will minimize it.

Make sure that you set the file compatibility property to 'Run this program as an administrator' for all users for both TestComplete.exe and TestExecute.exe

In your Project\Properties\Open Applications\General  move the NativeDelphiObject to the top of the list.

New Here?
Join us and watch the welcome video:
Announcements