cancel
Showing results for 
Search instead for 
Did you mean: 

Swaggerhub-generated JAX-RS server stubs act as if "delayDispatchUntilContent" is false?

Highlighted
pwd
Occasional Contributor

Swaggerhub-generated JAX-RS server stubs act as if "delayDispatchUntilContent" is false?

Hi,

 

I'm experimenting with an API on SwaggerHub and I've generated both client-side (cpprest) and server-side (JAX-RS) stubs from the API.

 

The strange part is that when I use a tool like Postman, which sends the complete request (headers and body) in a single packet, the server responds as expected but when I use the generated (cpprest) client stubs the request headers come in a first packet and the body in a second packet.  They re-assemble fine (I can see a valid-looking  combined packet in Wireshark) but it looks as if the server request is dispatched as soon as the headers arrive, without waiting for the body parameters to arrive (despite the "Content-length" header value).

 

As a result the server sees a request that's got a "null" value for the body parameter (even though the parameter is marked as "required"), as if "delayDispatchUntilContent" is false?  I've tried adding a "jetty.xml" file that explicitly defaults and sets "delayDispatchUntilContent" to "true" but that doesn't seem to make any difference.

 

Any idea what I'm missing here?  Any suggestions for a workaround, or a fix?

 

Thanks in advance!

-Patrick.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors
Top Kudoed Posts