cancel
Showing results for 
Search instead for 
Did you mean: 

Permissions error when creating new api in a project

SOLVED
eklaban
New Contributor

Permissions error when creating new api in a project

I have a 'Designer' member of a project within an Organization who is unable to create a new api within the project that she is a member of. However, she is able to successfully create an api within the Organization itself.

 

As the admin of our on-premise SwaggerHub deployment, I cannot find any reason that she would be unable to create a new api. Anyone have any ideas?

 

1 ACCEPTED SOLUTION

Accepted Solutions
LauraKennedy
Staff

Re: Permissions error when creating new api in a project

Hello,

 

We resolved an issue around Designers being unable to add APIs to Projects in our latest 1.27 release which was released mid April. This is a very important release as we have also upgrade Ubuntu to version 20 and Mongo db to 4.4. The versions on lower releases are now end of life so we are urging our customers to upgrade as soon as they can.

 

Instructions to upgrade can be found here > https://support.smartbear.com/swaggerhub/docs/enterprise/maintenance/upgrade.html

 

If you have any further questions please log a ticket with out support team.

 

Thks,

Laura Kennedy

 

View solution in original post

3 REPLIES 3
HKosova
Moderator

Re: Permissions error when creating new api in a project

Hi @eklaban,

 

Please open a support ticket so our team can help you troubleshoot the issue:

https://support.smartbear.com/swaggerhub/message/

 

and attach your system logs (Admin Center > System > Download Diagnostic Data) to the ticket.


Helen Kosova
SmartBear Documentation Team Lead
________________________
Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
LauraKennedy
Staff

Re: Permissions error when creating new api in a project

Hello,

 

We resolved an issue around Designers being unable to add APIs to Projects in our latest 1.27 release which was released mid April. This is a very important release as we have also upgrade Ubuntu to version 20 and Mongo db to 4.4. The versions on lower releases are now end of life so we are urging our customers to upgrade as soon as they can.

 

Instructions to upgrade can be found here > https://support.smartbear.com/swaggerhub/docs/enterprise/maintenance/upgrade.html

 

If you have any further questions please log a ticket with out support team.

 

Thks,

Laura Kennedy

 

View solution in original post

eklaban
New Contributor

Re: Permissions error when creating new api in a project

Thanks Laura! I'll try upgrading our on-premise version to the latest to see if that resolves the issue first.

 

Eric

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors