Ask a Question

swagger-ui version 4 configuration

Shriya
Frequent Visitor

swagger-ui version 4 configuration

My organisation's project is using swagger-ui version: 2.1.8. Swagger-ui needs to get updated to version 4. Downloaded source code from: swagger-api/swagger-ui: Swagger UI is a collection of HTML, JavaScript, and CSS assets that dynamica...

In the swagger version-4, As the url(localhost:3032) is hit, the code under dev-helpers/index.html folder is getting executed(v4). The steps under Plain old HTML/CSS/JS (Standalone) in the following link need to be followed. swagger-ui/installation.md at master · swagger-api/swagger-ui (github.com)

But the index.html responsible for creation of swagger-ui of new version is present in dev-helpers folder and the above link suggests only adding dist folder files to the project(not sure if this is right.....). In the previous(2.1.8) version, swagger-ui-bootstrap was getting generated at runtime, which is presently(v4) not taking place. I would like to completely understand the generation of swagger-ui webpage right from the 'localhost-3032' being hit. How can I approach this?

docs folder was of very little help. There is no .json file being assigned to url in the previous code of the organisation's project. No static file(.json) is involved in the complete project. the url is being taken from the browser url and the end points are being detected automatically(with no .json file created). And i need to update the swagger version 2.1.8 to swagger version-4. Any small lead would be of gr8 appreciation.

My organisation's project is using https://opensource.ncsa.illinois.edu/bitbucket/projects/CATS/repos/clowder/browse/public/docs/api?at... implementation to display the swagger-ui. I need to replace this exact implementaion to https://github.com/swagger-api/swagger-ui
Pls tell me how to do it.........

0 REPLIES 0
cancel
Showing results for 
Search instead for 
Did you mean: