cancel
Showing results for 
Search instead for 
Did you mean: 

dependency to spring-plugin.version 1.2.0.RELEASE

christopheAtMak
New Contributor

dependency to spring-plugin.version 1.2.0.RELEASE

Hello

I am facing the following strange situation

I use swagger hub to specify apis and codegen for spring boot to generate the server stubs and maven POM

This POM creates a dependency to spring-plugin.version 1.2.0.RELEASE  wich I can find nowhere in the dependencies. It looks like it conflicts (at lest this is what eclipse displays) with spring-plugin.version 2.0.0.RELEASE 

When the jar is generated & repackaged the wrong verion of th eplugin is  inserted in the resulting jar (1.2.0 instead of 2.0.0) and of course the microservice fails to start.

I have tried for hours to find ou where this dependency came from (as the maven tools I ran do not find it)

Can someone help me with this?

 

Regards

 

Christophe

 

New Here?
Join us and watch the welcome video:
Announcements