cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading to OpenAPI 3.0 - Compatibility issues

Highlighted
Occasional Visitor

Upgrading to OpenAPI 3.0 - Compatibility issues

Hi,

 

We are thinking to update our swagger specification from 2.0 to OpenAPI 3.0. Given that it is an existing API, would like to know if the Swagger spec update can be done in phased manner i.e. updating the swagger spec at server side first and give little window for consumers/customers to update the swagger specification at their end.

  • Will customers be able to continue using spec 2.0 after migrating to 3.0 at our end?

Felt it should be OK as a temporary solution, given that both specs are aligned i.e. no change in the overal request/response specifications.

 

Are there any known compatiability issues with this approach?

 

Thanks.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors