cancel
Showing results for 
Search instead for 
Did you mean: 

Swagger UI, after clicking Auth button on Auth popup showing Auth error 403

New Contributor

Swagger UI, after clicking Auth button on Auth popup showing Auth error 403

1.In swagger UI the after clicking on authorize button the popup window will load
2.on that pop up window click on Logout button.
3.keep popup window open then click Authorize button availableon that popup
4.then will show Auth error:403 message
3 REPLIES 3
Moderator

Re: Swagger UI, Auth prize button popup not showing properly

Can you provide more details? Which version of Swagger UI do you use? Can you share the definition you load into it? What do you mean by 'not showing properly'?


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Contributor

Re: Swagger UI, Auth prize button popup not showing properly

hello @RonRatovsky ,

Thanks for your reply,I am using swagger UI 3.23.9, follow the steps to create the issue:

1.Click on Authorize Button on swagger UI

2.after that Authorization Pop up window will open

3.enter auth client id and secrete key details on popup window fields

4.Click on Authorize button present on popup window.

5.Now we have successfully authorized ,then click on Logout button on popup.

6.Now we are gets successfully gets logout(but client Id and Secrete key fields are not getting cleared).

7.keep popup window remain open,click again on authorize button present on popup window

8.Then " Auth error:403 "error message we getting

 

Expected flow one of the below:

1.After clicking on logout button all feilds gets cleared.

2.After click on logout button fields value remain as it is but after clicking on authorized button it should gets authorized without any error.

 

Root cause:

----------------

authorization code are same in both request(after logout authorize and before as well) 

 

Please help me out with this issue.

Thanks In advance.

Moderator

Re: Swagger UI, Auth prize button popup not showing properly

Thanks for sharing the step details, very very helpful. Can you please also share the API definition that's loaded into Swagger UI for us to check? If you can't share the exact definition, one that would show the same problem is also an option.


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Here?
Join us and watch the welcome video: