cancel
Showing results for 
Search instead for 
Did you mean: 

Swagger Hub - Swagger Editor | Not able to see externalDocs hyperlink in exported HTML

aartinagdev
Occasional Contributor

Swagger Hub - Swagger Editor | Not able to see externalDocs hyperlink in exported HTML

I am using Swagger Editor for documenting my API specification with OAS version 3.0.0 and need to link external documentation in it. I tried using externalDocs tag as below:

externalDocs:
description: Third Party Documentation
url: file:///D:/Doc/Request.pdf

I am able to see a hyperlink when I do View Documentation from Swagger Hub, but the same is missing in exported documentation in HTML Format.

2 REPLIES 2
HKosova
Moderator

Re: Swagger Hub - Swagger Editor | Not able to see externalDocs hyperlink in exported HTML

Hi @aartinagdev,

This looks like a known issue with codegen HTML output:

https://github.com/swagger-api/swagger-codegen/issues/4861

You can follow this GitHub issue for updates to get notified when it gets fixed.


Helen Kosova
SmartBear Documentation Team Lead
________________________
Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
aartinagdev
Occasional Contributor

Re: Swagger Hub - Swagger Editor | Not able to see externalDocs hyperlink in exported HTML

Hi @HKosova , thanks for the reply. I am facing similar issue as in the below github link but with OAS Version 3.0.0. Can you confirm if the issue still persists in 3.0.0 or there is something that I have to incorporate from my side. If the case is former, is there any workaround or expected time frame for the fix that I can look forward to ?

New Here?
Join us and watch the welcome video: