Ask a Question

Links in OAS 2.0 specification page are broken

k_sze
Occasional Visitor

Links in OAS 2.0 specification page are broken

I've tried in the latest version of Mozilla Firefox, Google Chrome, and Microsoft Edge; even with all privacy protections disabled. Same results everywhere.

  1. Open you browser - e.g. Mozilla Firefox
  2. Open the developer console of your browser
  3. Open https://swagger.io/specification/v2/#data-types in the browser; you would land in the "Data Types" section of the OAS 2.0 specifications.
  4. Immediately you should see a message like this in the console:
  5. k_sze_1-1633403233055.png

    In the second paragraph of that "Data Types" section, click the "Parameter Object" link;

  6. You should see messages like these in the console:
  7. k_sze_2-1633403277134.png

    And of course you can't actually jump to the section with that link.

2 REPLIES 2
ponelat
Staff

Re: Links in OAS 2.0 specification page are broken

Thanks @k_sze for spotting this! 

 

@HKosova is this something you could look into? 

HKosova
Moderator

Re: Links in OAS 2.0 specification page are broken

@k_sze thanks for the report, I've passed this on to our web team.

 

In the meantime, you can read the 2.0 Specification here:

https://spec.openapis.org/oas/v2.0

 

 


Helen Kosova
SmartBear Documentation Team Lead
________________________
Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
cancel
Showing results for 
Search instead for 
Did you mean: