cancel
Showing results for 
Search instead for 
Did you mean: 

projects hanging when running via testrunner, testsuite runtype = parallel

Highlighted
Super Contributor

projects hanging when running via testrunner, testsuite runtype = parallel

sometimes my projects hang when testsuite runtype is parallel. I believe this is related to the problem i reported earlier but was not quite fixed.

The log shows something like this
11:40:41,790 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser
11:40:46,790 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser
11:40:51,790 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser
11:40:56,790 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser
11:41:01,790 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser
11:41:06,790 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser
11:41:11,789 INFO  [SoapUIProTestCaseRunner] Waiting for 1 tests to finish:
- LinkDevice_Invalid:LinkDevice_InvalidPartner_Ignored_PNE:RUNNING:UserProfileService.AuthenticateUser


When the runtype option is set to sequential, I dont believe I see the problem.

I needed two things from eviware to address this problem.

1. hopefully this issue can be fixed
2. since I have a load script in each project, is it possible to change the runtype to SEQUENTIAL for all testsuites when the project loads.
so something like
  for all testsuites in project
  runtype = SEQUENTIAL

this is at least take care of the problem temporarily.

Thanks

Ali
1 REPLY 1
Highlighted

Re: projects hanging when running via testrunner, testsuite runtype = parallel

Hi Ali,

What you could do is write a project save script, that would look something like this:


import com.eviware.soapui.model.testsuite.TestSuite.TestSuiteRunType;
for( testSuite in project.testSuiteList )
      testSuite.runType = TestSuiteRunType.SEQUENTIAL


That will set all your TestSuites runType to SEQUENTIAL when you save the project, although if you have TestSuites opened you'll have to reopen them to see the changes, since they won't be refreshed.

Regards,

/Dragica
eviware.com


 Join the virtual SmartBear Connect user conference on April 27-28! Get your free virtual ticket today!