cancel
Showing results for 
Search instead for 
Did you mean: 

invaild chars in request body

New Contributor

invaild chars in request body

hello, 

 

 

i try to send a simple (REST)post request with a json body.

The problem is SOAP UI NG isn't able to add a vaild json body (see attachment), instead of that they are invaild chars.

Related to this problem the endpoint throws an expection.

If using postman everthing works fine.

 

Version.

Ready API 2.0.0

 

i hope you can help 

 

regards,

 

Alex

5 REPLIES 5
Contributor

Re: invaild chars in request body

Hi, I've seen in the forums before that using Lucida Sans Unicode font or setting Preferences > UI Settings to default look and feel fixes some issues with special characters. Then one of my coworkers suggested to select the REST test step, check on the Properties, and click on the field for the encoding. You have the option there to select ISO or UTF. You might want to try those. The last one worked on our end when foreign characters were getting converted to weird characters.

"an Engineer without a degree, a QA tester without any official certification (just yet ;-) ) "
New Contributor

Re: invaild chars in request body

Hi, I've seen in the forums before that using Lucida Sans Unicode font or setting Preferences > UI Settings to default look and feel fixes some issues with special characters.

 

This setting is not available in Ready API, or iam confused

 

Then one of my coworkers suggested to select the REST test step, check on the Properties, and click on the field for the encoding. You have the option there to select ISO or UTF. You might want to try those. The last one worked on our end when foreign characters were getting converted to weird characters.

 

i tried once to UFT-8 and iso it does'nt work :-(  see attachment

 

Staff

Re: invaild chars in request body

> This setting is not available in Ready API, or iam confused

 

Its probably in the Editor tab.

 

Not sure what causes such behavior through. If no one here can help, make sure to contact the support team, they will either help or ask the developers for a solution.

API Bloom
Contributor

Re: invaild chars in request body

Hi, sorry. I was thinking SoapUI's Preferences might have been the same as Ready!API, with Ready!API having more customization options. It seems different now when I opened 2.0. Now, I'm wondering what's in that request body that's being converted. Anyway, if that would be something that can't be shared within the forums/community, maybe you could drop a mail to SmartBear for support so they can assist you: ReadY!API Technical Support.

 

@IgorG, it used to be a workaround for those who had issues with character displays. The developers I've worked with, shared some pages about it when I was working with Israeli inputs. I've also seen some who had issues with Chinese and special characters. It seems that nowadays, the only available option is the font at Editor and the encoding options (UTF and ISO) at Project Properties. I'm attaching screenshots for comparison of SoapUI Open Source and Ready!API. Currently, my work requires me to coordinate with users of both SoapUI Open Source  and Ready!API (1.8 and migrated to 2.0 during the release day.)

uiOptions.png

 

 

EditorSettings.png

 

It seems that Native look and feel is no longer present but font is still there. Here's one of the previous issues which shows why they re-added it on older versions: https://community.smartbear.com/t5/SoapUI-NG/SoapUI-3-6-Look-amp-Feel-on-Mac-OS/td-p/15256

 

 

 

 

"an Engineer without a degree, a QA tester without any official certification (just yet ;-) ) "
Contributor

Re: invaild chars in request body

Hi, sorry. I was thinking SoapUI's Preferences might have been the same as Ready!API, with Ready!API having more customization options. It seems different now when I opened 2.0. Now, I'm wondering what's in that request body that's being converted. Anyway, if that would be something that can't be shared within the forums/community, maybe you could drop a mail to SmartBear for support so they can assist you: ReadY!API Technical Support.
 
@IgorG, it used to be a workaround for those who had issues with character displays. The developers I've worked with, shared some pages about it when I was working with Israeli inputs. I've also seen some who had issues with Chinese and special characters. It seems that nowadays, the only available option is the font at Editor and the encoding options (UTF and ISO) at Project Properties. I'm attaching screenshots for comparison of SoapUI Open Source and Ready!API. Currently, my work requires me to coordinate with users of both SoapUI Open Source  and Ready!API (1.8 and migrated to 2.0 during the release day.)
uiOptions.png

 

EditorSettings.pngIt seems that Native look and feel is no longer present but font is still there. Here's one of the previous issues which shows why they re-added it on older versions: https://community.smartbear.com/t5/SoapUI-NG/SoapUI-3-6-Look-amp-Feel-on-Mac-OS/td-p/15256

 

"an Engineer without a degree, a QA tester without any official certification (just yet ;-) ) "
New Here?
Join us and watch the welcome video:
Top Kudoed Authors