cancel
Showing results for 
Search instead for 
Did you mean: 

Unknown Swagger version error during import

Occasional Contributor

Unknown Swagger version error during import

Hi All,

 

I'm trying to import a Swagger file v2.0 in ReadtyAPI, but I'm getting an error "java.lang.RuntimeException: Unknown Swagger Version: null" as below

Capture.JPG

I'm not able to install the plugin as well from the Plugin manager due to company restrictions. I can only see the installed plugins, and available plugins are not displayed as below

Capture1.JPG

Any idea why this swagger import is failing? If it's due to the missing plugin, is there an alternative way to add it?

 

Thanks

6 REPLIES 6
Community Leader

Re: Unknown Swagger version error during import

Which version of ReadyAPI are you using? Also, Could you please check your -home-/.readyapi/plugins folder that it doesn't contain multiple versions of the plugin? 

Occasional Contributor

Re: Unknown Swagger version error during import

Hi,

 

I'm using Ready API 2.4.0 on Windows. I checked the lib folder, and found the following jar files.

Capture2.JPG

Is this what you were asking to check?

Community Leader

Re: Unknown Swagger version error during import

No, these are the lib files which is inside ext folder. Chekc this path - home-/.readyapi/plugins. You will have this .readyapi folder inside - C://users/AvidCoder/.readyapi/plugins.

Occasional Contributor

Re: Unknown Swagger version error during import

There is no plugins folder in that path. I think it might be due to company restrictions.

Occasional Contributor

Re: Unknown Swagger version error during import

By the way, I forgot to mention that the file I'm trying to import is an Open API version 3.0.1 file

Community Leader

Re: Unknown Swagger version error during import

Yes may be.. But I think, you have multiple version of swagger plugin existing there. This might be the real problem.

Ask a SmartBear
Top Kudoed Authors