cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to run tests from the Suite Level ReadyAPI 2.7

SOLVED
New Contributor

Unable to run tests from the Suite Level ReadyAPI 2.7

I have a project with a large resource definition listing. Using ReadyAPI 2.6 I was able to select a suite an run all of the test cases within that suite. After upgrading to 2.7 I am unable to run the tests from the test suite level. I click on the test suite and I am not presented with the option to run the whole suite or if I am able to see the option to run the suite clicking on the play button results in no action. 

 

The only way I can run the whole suite is to do so from the command line. The resouce definition lisitng for this project contains about 370 items. I'm in the process of rolling back to 2.6 to verify that the issue is only in 2.7 but I wanted to see if anyone else is having this problem. 

 

I check the release note for 2.7 and I see that the change (RIA‑9084) mentions improving performance for large definition listings and I'm wondering if this may have had an unintended impact to what I'm seeing. 

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: Unable to run tests from the Suite Level ReadyAPI 2.7

Hey @Nukeem 

 

If you get the 'normal' behaviour if you delete some of the testsuites out of your project - can you confirm it works like this if you delete different testsuites?  (this is my final check before I suggest the following)

 

Have you tried increasing the resourcing available to ReadyAPI!?  check out the following link https://support.smartbear.com/readyapi/docs/testing/best-practices/memory-usage.html

 

I'd follow the instructions here to disable test history as well as cranking the resource profile available to ReadyAPI! to max (updating .vmoptions file)

 

If this fails to give you what you need - you can raise a support request - but eventually ReadyAPI! IS going to run out of resource depending on the size and complexity of the XML loaded into memory eventually anyway....you just nee to check that the issue you are facing occurs when all available resources are consumed and not before.

 

Ta,

 

richie

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
4 REPLIES 4
Community Hero

Re: Unable to run tests from the Suite Level ReadyAPI 2.7

Hi @Nukeem,

Have you got any other projects in your workspace?
I'm guessing this behaviour is project specific, but i'm wondering how ReadyAPI! is behaving for other projects within the same workspace simultaneously...

Cheers

Richie

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
New Contributor

Re: Unable to run tests from the Suite Level ReadyAPI 2.7

If I have a different project in the same worksapace, and a smaller resource definition, the running of the test suites behaves as expected. As soon as I start trying to select the Suites in the problem project I see the undesired behavior again.

 

An additional note, if I delete the resource definitions, I can then select the Suites and run them.

Community Hero

Re: Unable to run tests from the Suite Level ReadyAPI 2.7

Hey @Nukeem 

 

If you get the 'normal' behaviour if you delete some of the testsuites out of your project - can you confirm it works like this if you delete different testsuites?  (this is my final check before I suggest the following)

 

Have you tried increasing the resourcing available to ReadyAPI!?  check out the following link https://support.smartbear.com/readyapi/docs/testing/best-practices/memory-usage.html

 

I'd follow the instructions here to disable test history as well as cranking the resource profile available to ReadyAPI! to max (updating .vmoptions file)

 

If this fails to give you what you need - you can raise a support request - but eventually ReadyAPI! IS going to run out of resource depending on the size and complexity of the XML loaded into memory eventually anyway....you just nee to check that the issue you are facing occurs when all available resources are consumed and not before.

 

Ta,

 

richie

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
New Contributor

Re: Unable to run tests from the Suite Level ReadyAPI 2.7

I tried to increase the memory and the disabing the test case history and it didn't help. I created a support ticket as you suggested. Thanks for your assistance!

New Here?
Join us and watch the welcome video:
Top Kudoed Authors