cancel
Showing results for 
Search instead for 
Did you mean: 

TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

SOLVED
Occasional Contributor

TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

A TestStep of type Run TestCase does not work similiar to SoapUI NG 1.4.1 and older versions. If you use Run Mode: Create isolated copy for each run (ThreadSafe) the property values are always copied to the target testcase which will be executed by the Run TestCase.

 

This issue caused the following unsightly side effects:

  • The default Target-TestCase properties are changed after every execution (not comaptible with version management tools - in my case SVN) - also if you set the option Does not set empty TestCase property values Robot surprised
  • You can not use and define default values in your Target-TestCase
1 ACCEPTED SOLUTION

Accepted Solutions
Community Manager

Re: TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

Hi Nicorette,

 

I was informed that our Team is preparing a maintenance build that should fix the issue. It should be available in an hour or so.

 

---------
Tanya Gorbunova
SmartBear Community Manager

Join the annual community event and share your stories to win gifts
Wintertainment2019

View solution in original post

4 REPLIES 4
Community Manager

Re: TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

Hi Nicorette,

 

I've reported this behavior to our R&D team. Thanks.

---------
Tanya Gorbunova
SmartBear Community Manager

Join the annual community event and share your stories to win gifts
Wintertainment2019
Community Manager

Re: TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

Hi Nicorette,

 

I was informed that our Team is preparing a maintenance build that should fix the issue. It should be available in an hour or so.

 

---------
Tanya Gorbunova
SmartBear Community Manager

Join the annual community event and share your stories to win gifts
Wintertainment2019

View solution in original post

Occasional Contributor

Re: TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

Hello,

the software is now working as expected.

Contributor

Re: TestStep "Run TestCase" works different in 1.5.0 (Snapshot)

The run test cas wont work in Ready Api, I added this step to run a update account testcase befroe executing itself but the testcase fails rightaway. The only way I can run it is by disabling the 'runtestcase' 

There is no issue with update account testcase, it works fine