cancel
Showing results for 
Search instead for 
Did you mean: 

Switching to Form view and back to XML view deletes field tags that were blank.

Occasional Contributor

Switching to Form view and back to XML view deletes field tags that were blank.

 My  XML file contains following structure:

               <!--Optional:-->
                  <abc: State/>
                  <!--Optional:-->
                  <abc: PostalCode/>
                  <!--Optional:-->
                  <abc: Country/>

 

After switching to Form view and back to XML the same area looks like that:

                  <!--Optional:-->
                 
                  <!--Optional:-->
                 
                  <!--Optional:-->

 

Is it a bug? 

8 REPLIES 8
Community Manager

Re: Switching to Form view and back to XML view deletes field tags that were blank.

Hi Svetlana,

 

That’s strange. I would suggest that you check if the same behavior is reproduced in the latest maintenance build. You can download it here: https://support.smartbear.com/downloads/readyapi/nightly-builds/

 

BTW, do you see the same behavior when using the following structure?

<!--Optional:-->
   <abc: State></abc: State>

 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

Re: Switching to Form view and back to XML view deletes field tags that were blank.

Hi Tanya,

 

Thank you for your prompt reply.

 

I installed the maitenance build using the link you provided. After installation an instance of regular Ready API was launched automatically. I encountered absolutely the same issue as I described yesterday. Structure <abc: State></abc: State> didn't make any difference. This tag was deleted anyway.

 

Then I manually ran another instance of Ready API Snapshot from Windows menu. The behavior was slightly different: an Error showed up with following text: Do you want to recreate a default message from the schema? I clicked No and all the fields dissapeared from Form view but xml file wasn't blanked out. Running my service created an error.

 

Then I closed current Ready API Snapshot instance and launched another one. This time I answered Yes to the error message. It set all the fields to "?" value but kept the structure in both Form and XML views.

 

I think I will stick with regular Ready API rather than Snapshot. If I don't switch to Form view, Ready API allows me to run services based on an XML file.

 

Community Manager

Re: Switching to Form view and back to XML view deletes field tags that were blank.

Hi Svetlana,

 

The behavior you describe is very strange (several Ready! API instances shouldn’t work differently). Could you please contact our Ready! API Customer Care Team ( http://support.smartbear.com/product-list/ ) to analyze this behavior and to come to the solution?

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

Re: Switching to Form view and back to XML view deletes field tags that were blank.

I contacted Ready! API Customer Care Team with this issue. Thank you, Tanya!

Occasional Contributor

Re: Switching to Form view and back to XML view deletes field tags that were blank.

This "bug" is not new.  This has been a problem in SoapUI since as long as I can remember.

New Contributor

Re: Switching to Form view and back to XML view deletes field tags that were blank.

This is still an issue in 2019. Is there a plan to fix it?

Re: Switching to Form view and back to XML view deletes field tags that were blank.

Hi @mal_game,

 

I can't reproduce the issue in ReadyAPI 2.6.0. Can you update ReadyAPI to the latest version, which is 2.6.0: https://support.smartbear.com/downloads/readyapi and let me know whether it helps?


Kirill Zakharov
Customer Care Team

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Contributor

Re: Switching to Form view and back to XML view deletes field tags that were blank.

That is the version I have. I have attached some screen shots. Before and after. You can see the gaps left by ReadyAPI. Doesn't always happen. You may have to click between XML and Form several times.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors