cancel
Showing results for 
Search instead for 
Did you mean: 

Struggling to add a MIMER JDBC DB Driver To SoapUI

SOLVED
Highlighted
Community Hero

Struggling to add a MIMER JDBC DB Driver To SoapUI

Hey,

 

I'm using ReadyAPI! (SoapUI) and the database I am publishing a message to is a MIMER database (no I hadn't heard of a MIMER database either - apparently it's a relational model thats been around for 25years!

 

With this in mind I'm attempting to add in the .jar file and configure the JDBC connection settings but I'm not having any luck.

 

I'm hoping someone can help.

 

I got the supporting info from 

http://developer.mimer.com/howto/howto_17.htm

Anyway - I downloaded the .zip file that contains the .jar file

 

I then copied the .jar file (mimjdbc3.jar) to 

 

C:\Program Files\SmartBear\ReadyAPI-2.1.0\lib

The website indicates the connection string format and the driver name

 

Connection string format 

jdbc:mimer:[//[user[:password]@]host[:port]] [/database]

 

Driver name 

com.mimer.jdbc.Driver

 

I went to the Global Preferences (JDBC) and clicked on the add button.

 

I then specified the driver name = 

com.mimer.jdbc.Driver

and the connection string

 

jdbc:mimer:[//[user[:password]@]host[:port]] [/database]

 

 

HOWEVER - when I clicked on the 'Load driver values from an external file' button (which I was then going to point to the .jar file I've saved to 

C:\Program Files\SmartBear\ReadyAPI-2.1.0\lib

 

I get an error response 'Failed to load drivers from [C:\Program Files\SmartBear\ReadyAPI-2.1.0\lib\mimjdbc3.jar]; java.lang.IllegalArgumentException: Malformed \uxxxx encoding.'

 

Can anyone please advise?

 

Thanks in advance 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
12 REPLIES 12
Highlighted
Community Hero

will do - someone's borrowed my environment at the moment and they've switched the runtime back to 1.8 rather than 1.2 - as soon as they're out the environment I will repeat!

 

Thanks

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Hero

Hi,

 

OK - I've attached the ReadyAPI! Log and the Error Log file entries

 

I've added an extract of the ReadyAPI! Log below:

 

 

Wed Aug 16 15:20:41 BST 2017:INFO:ReadyAPI 2.1.0 started - System properties: {OS=Windows Server 2016, User name=PYWE0001}
Wed Aug 16 15:20:41 BST 2017:INFO:Adding [C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext\mimjdbc3.jar] to extensions classpath
Wed Aug 16 15:20:41 BST 2017:INFO:Adding [C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext\postgresql-9.3-1102.jdbc41.jar] to extensions classpath
Wed Aug 16 15:20:41 BST 2017:INFO:Adding [C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext\sqljdbc42.jar] to extensions classpath
Wed Aug 16 15:20:42 BST 2017:INFO:Registered 2 JDBC drivers from extensions directory: [org.postgresql.Driver, com.microsoft.sqlserver.jdbc.SQLServerDriver]

Above - you can see - it finds the mimjdbc3.jar file which I've added to the bin/ext directory and you can see the postgresql and sqlserver  .jar files as well (the postgresql and sqlserver .jar files were already present - I didn't add these).

 

Next - you can see it SoapUI registered only 2 of the JDBC drivers - the existing postgresql and sqlserver  drivers - it doesn't register the MIMER db .jar file (mimjdbc3.jar)

 

The error logs the following when I tried making a connection to the MIMER database 

 

Wed Aug 16 15:27:10 BST 2017:ERROR:An error occurred when getting a driver for the connection string [jdbc.mimer://PULS_QL:PULS_QL@TSTC03:1360/NBTSTML].
Wed Aug 16 15:27:10 BST 2017:ERROR:java.sql.SQLException: No suitable driver
   java.sql.SQLException: No suitable driver

 

I've attached the error & ReadyAPI! logs

 

Again - thanks to all

 

richie

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Hero

I've sorted it out - although the setup appears quite specific

 

I know it's unlikely as no one uses MIMER databases really but just in case, for future reference for anyone needing to connect to a MIMER DB via SoapUI - follow these instructions:

 

note: any version of MIMER db < v8.2 requires JDK v1.1, versions > v8.2 requires JDK v1.2.  The version of MIMER DB I was using was v10.0.61

 

1.  Install JDK v1.2

2.  Ensure PATH environment variable doesn't point to another version of Java

3.  Set JAVA_HOME to JDKv1.2's bin directory (e.g. C:\jdkv1.2.2\bin) - e.g. at command prompt run 'set JAVA_HOME=%JAVA_HOME%;C:\jdkv1.2.2\bin'

4.  At command prompt run 'java -version' to ensure it's picking up JDKv1.2 rather than other versions of Java

5.  Download the mimer jdbc driver file (mimjdbc3.jar) and copy this to 'C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext'

6.  Create or  update the CLASSPATH environment variable, pointing to the location of the .jar file.  Run the following command via command prompt 'set CLASSPATH=%CLASSPATH%;C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext'

7.  Within SoapUI's JDBC preferences, add in an entry - 'Driver column' value = 'UniqueIdentifier/com.mimer.jdbc.Driver'.  In the 'Connection String Template' column add in the value 'jdbc:mimer://<USER>:<PASSWORD>@<HOST>:<PORT:1360>/DB.  (note: other variations of the connection string didn't work - I got a driver failed to initialise error response).

 

 

That's it.  If you follow the above instructions, this creates the connection successfully.  If I deviated (or missed out) any of the instructions above, I'd get a driver failed to initialise connection response when I tried to connect to the database.

 

Thanks to all!

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
TechCorner Leaderboard
Want a fun and easy way to learn ReadyAPI and show off your skills? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Get a full Raw JMS request

Participate!

Compare an expected JSON value and actual response in Events

Participate!

Fetch value/data from JSON response using Groovy Script

See replies!

Get data from Petstore and add it to Excel sheets

Participate!
Top Kudoed Authors