cancel
Showing results for 
Search instead for 
Did you mean: 

Struggling to add a MIMER JDBC DB Driver To SoapUI

SOLVED
Highlighted
Community Hero

Struggling to add a MIMER JDBC DB Driver To SoapUI

Hey,

 

I'm using ReadyAPI! (SoapUI) and the database I am publishing a message to is a MIMER database (no I hadn't heard of a MIMER database either - apparently it's a relational model thats been around for 25years!

 

With this in mind I'm attempting to add in the .jar file and configure the JDBC connection settings but I'm not having any luck.

 

I'm hoping someone can help.

 

I got the supporting info from 

http://developer.mimer.com/howto/howto_17.htm

Anyway - I downloaded the .zip file that contains the .jar file

 

I then copied the .jar file (mimjdbc3.jar) to 

 

C:\Program Files\SmartBear\ReadyAPI-2.1.0\lib

The website indicates the connection string format and the driver name

 

Connection string format 

jdbc:mimer:[//[user[:password]@]host[:port]] [/database]

 

Driver name 

com.mimer.jdbc.Driver

 

I went to the Global Preferences (JDBC) and clicked on the add button.

 

I then specified the driver name = 

com.mimer.jdbc.Driver

and the connection string

 

jdbc:mimer:[//[user[:password]@]host[:port]] [/database]

 

 

HOWEVER - when I clicked on the 'Load driver values from an external file' button (which I was then going to point to the .jar file I've saved to 

C:\Program Files\SmartBear\ReadyAPI-2.1.0\lib

 

I get an error response 'Failed to load drivers from [C:\Program Files\SmartBear\ReadyAPI-2.1.0\lib\mimjdbc3.jar]; java.lang.IllegalArgumentException: Malformed \uxxxx encoding.'

 

Can anyone please advise?

 

Thanks in advance 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

I've sorted it out - although the setup appears quite specific

 

I know it's unlikely as no one uses MIMER databases really but just in case, for future reference for anyone needing to connect to a MIMER DB via SoapUI - follow these instructions:

 

note: any version of MIMER db < v8.2 requires JDK v1.1, versions > v8.2 requires JDK v1.2.  The version of MIMER DB I was using was v10.0.61

 

1.  Install JDK v1.2

2.  Ensure PATH environment variable doesn't point to another version of Java

3.  Set JAVA_HOME to JDKv1.2's bin directory (e.g. C:\jdkv1.2.2\bin) - e.g. at command prompt run 'set JAVA_HOME=%JAVA_HOME%;C:\jdkv1.2.2\bin'

4.  At command prompt run 'java -version' to ensure it's picking up JDKv1.2 rather than other versions of Java

5.  Download the mimer jdbc driver file (mimjdbc3.jar) and copy this to 'C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext'

6.  Create or  update the CLASSPATH environment variable, pointing to the location of the .jar file.  Run the following command via command prompt 'set CLASSPATH=%CLASSPATH%;C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext'

7.  Within SoapUI's JDBC preferences, add in an entry - 'Driver column' value = 'UniqueIdentifier/com.mimer.jdbc.Driver'.  In the 'Connection String Template' column add in the value 'jdbc:mimer://<USER>:<PASSWORD>@<HOST>:<PORT:1360>/DB.  (note: other variations of the connection string didn't work - I got a driver failed to initialise error response).

 

 

That's it.  If you follow the above instructions, this creates the connection successfully.  If I deviated (or missed out) any of the instructions above, I'd get a driver failed to initialise connection response when I tried to connect to the database.

 

Thanks to all!

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

12 REPLIES 12
Highlighted
Community Hero

One thing I can point out is you need to place the jar here:

 

C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext

based on the documentation here. Other than that, that documentation references mySql but might be able to shed some light on how to set it up.

 

If the JDBC driver itself is giving an error that might be something you have to contact the provider for that JAR on.




---

Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Highlighted
Community Hero

Cheers,

 

I know the driver and .jar works correctly because they used it with some DB interrogation tool called WSQL - I just wanted to make sure I've got the process of adding a new JDBC driver into Soapui.

 

I did read that I'd put the .jar file in the wrong place - so thanks for that!

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Hero

Let me know if getting it in the right folder helps or if there are still problems. 🙂 




---

Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Highlighted
Community Hero

Hey!

 

I'm afraid I still have problems -I've done a google search for MIMER and SoapUI and it doesn't look like anyone's tried this before (honestly - whats wrong with Oracle?...I like Oracle and it's easy to setup!)

 

I added the .jar file into the correct directory and inserted the value com.mimer.jdbc.Driver into the 'Driver' column but as soon as I point to the file (saved in C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext) i get the following error response

 

'Failed to load drivers from [C:\Program Files\SmartBear\ReadyAPI-2.1.0\bin\ext\mimjdbc3.jar]; java.lang.IllegalArgumentException: Malformed \uxxxx encoding.'

 

I know there's a performance tester here using JMeter and he's using the  .jar file without any problems - I've sent him an email -unsure what else to do at the moment!

 

Thanks for the help fella,

 

richie

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Hero

Okay, I'm walking through this but without a Mimer sql database to test against I am limited. Once you have the JDBC jar file in the \bin\ext folder and restart ReadyAPI you have to set up the JDBC connection.

 

File -> Preferences -> JDBC Drivers

 

Click "+" button to add a new driver.

Driver name: 

MimerSQL/com.mimer.jdbc.Driver

Connection String Template:

jdbc:mimer://<USER>:<PASSWORD>@<HOST>:<PORT:1360>/<DB>

Once you have that, you should be able to go to your project and add a database connection.

 

Under the Databases window, click the "+" button to add a database connection.

Provide a name, click OK.

Select the Mimer entry under the Driver drop down.

Enter in the HOST, PORT, USER, Password, and Database values and click the "Test Conncetion"

 

I was able to mock that up and make it work. Maybe that'll help.




---

Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Highlighted
Community Hero

thanks fella - I got this far myself, but I'm getting a 'Failed to initialize the connection that uses the [com.mimer.jdbc.Driver] driver' for each of the last 6 permutations I've tried myself.

 

I suspect this 'failure to initialise' is because I haven't been able to point the driver entry in the JDBC preferences to the .jar file in the SoapUI/bin/ext directory.

 

Appreciate all the help though!

 

Many thanks!

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Hero

You don't have to point ReadyAPI to the jar file. It's loaded into memory the moment you place it in the \bin\ext folder and start up ReadyAPI. After that it's all configuration. 

 

You have to provide the driver a name and a namespace, that's how it knows to use the JAR it's already loaded. 




---

Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Highlighted
Community Hero

hhmmm -  other posts around this are because people forgot to put the .jar file in there - or they had an incorrect versioning between the .jar file and the Java version - they didn't need to point the entry in the JDBC settings in the global preferences to the file in the bin/ext folder......

 

making me think maybe there's a problem wiht the .jar file I'm using.

 

trouble us the latest Java version I can use is 1.2 - this doesn't fill me with a lot of confidence!

 

Thanks again!

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Hero

Hope the ready api is restarted after placing the library file under READYAPI_HOME/bin/ext directory.

Would you mind posting the log file?


Regards,
Rao.
New Here?
Join us and watch the welcome video:
Announcements
TechCorner Leaderboard
Want a fun and easy way to learn ReadyAPI and show off your skills? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Get a full Raw JMS request

Participate!

Compare an expected JSON value and actual response in Events

Participate!

Fetch value/data from JSON response using Groovy Script

See replies!

Get data from Petstore and add it to Excel sheets

Participate!
Top Kudoed Authors