cancel
Showing results for 
Search instead for 
Did you mean: 

Slow startup is back! v1.8.0

New Contributor

Slow startup is back! v1.8.0

I have latest of ReadyAPI and the startup is extremely slow. Opening requests is slow as well. Only two small projects are open. Everything else is  closed.

 

Takes more time for Ready API to launch than my computer boot time!!

Tags (2)
7 REPLIES 7
Community Manager

Re: Slow startup is back! v1.8.0

Hi Soodvarun,

 

 

Could you please check if the steps listed in the following article helps you?

http://readyapi.smartbear.com/soapui/working/improving_memory_usage

 

If they don't help, I recommend that you refer this issue to our Ready! API Customer Care Team

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Staff

Re: Slow startup is back! v1.8.0

Try this,

 

Download nightly build 64 bit and add these settings,

https://support.smartbear.com/downloads/readyapi/nightly-builds/

In your Ready API installation folder, in the Contents directory, please find the vmoptions file and open it in a text editor.
Add these lines to the file:
Edit the vmoptions file in Ready API Pro installation folder\bin folder for windows and for Mac Applications/Ready-API-Home.app/Contents/ to accommodate following changes,
Set Xms128m and -Xmx to 4000 if your ram is 4GB or 8000 if its 8GB
-XX:MaxPermSize=128m
-XX:MinHeapFreeRatio=40
-XX:MaxHeapFreeRatio=70
-Dsoapui.jxbrowser.disable=true
-Dtest.history.disabled=true

 

Once you do this, go to .readyapi folder in user folder > delete the contents of the db directory.

 

Close and restart Ready API

 


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Contributor

Re: Slow startup is back! v1.8.0

I tried but it did not help. It took 1 minute 45 seconds to load. Bellow is the new config for vmoptions. 

 

I have iCore7 and 16GB RAM on my machine. Machine is not the problem.

 

-XX:MaxPermSize=128m
-XX:MinHeapFreeRatio=40
-XX:MaxHeapFreeRatio=70
-Dsoapui.jxbrowser.disable=true
-Dtest.history.disabled=true
-Xms128m
-Xmx8000m
-Dsoapui.properties=soapui.properties
-Dsoapui.home=C:\Program Files\SmartBear\ReadyAPI-1.8.0/bin
-Dsoapui.ext.libraries=C:\Program Files\SmartBear\ReadyAPI-1.8.0/bin/ext
-Dsoapui.ext.listeners=C:\Program Files\SmartBear\ReadyAPI-1.8.0/bin/listeners
-Dsoapui.ext.actions=C:\Program Files\SmartBear\ReadyAPI-1.8.0/bin/actions
-Dwsi.dir=C:\Program Files\SmartBear\ReadyAPI-1.8.0/wsi-test-tools
-Djava.library.path=C:\Program Files\SmartBear\ReadyAPI-1.8.0/bin
-Djava.util.Arrays.useLegacyMergeSort=true
-Dsun.net.http.allowRestrictedHeaders=true

Staff

Re: Slow startup is back! v1.8.0

Go in File > Preferences > Ready API > Change Request editors for SOAP to Source  and REST to request. Close and reopen see if that helps.

 

 


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Contributor

Re: Slow startup is back! v1.8.0

Sorry, did not help. Is there some profiling or other info i can send you guys which can help debug this problem?

Occasional Contributor

Re: Slow startup is back! v1.8.0


@JKambli wrote:

Try this,

 

Download nightly build 64 bit and add these settings,

https://support.smartbear.com/downloads/readyapi/nightly-builds/

In your Ready API installation folder, in the Contents directory, please find the vmoptions file and open it in a text editor.
Add these lines to the file:
Edit the vmoptions file in Ready API Pro installation folder\bin folder for windows and for Mac Applications/Ready-API-Home.app/Contents/ to accommodate following changes,
Set Xms128m and -Xmx to 4000 if your ram is 4GB or 8000 if its 8GB
-XX:MaxPermSize=128m
-XX:MinHeapFreeRatio=40
-XX:MaxHeapFreeRatio=70
-Dsoapui.jxbrowser.disable=true
-Dtest.history.disabled=true

 

Once you do this, go to .readyapi folder in user folder > delete the contents of the db directory.

 

Close and restart Ready API

 


This worked for me to fix slow startup in v2.5.0

I know this is an old topic but it worked instantly, I think it was mainly because I had over 100MB of data in the db folder.

Occasional Contributor

Re: Slow startup is back! v1.8.0

Deleting the contents of the db folder does the trick for me (speaking of ReadyApi version 2.6.0).

Editing .vmoptions apparantly did not have that impact. It did for version 2.4.0 however.

It seems to me this is a particular issue of version 2.6.0.

Looks like I have to do the deletion step once in a while, unless there is a smarter move.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors