cancel
Showing results for 
Search instead for 
Did you mean: 

SecurePro parameter substitutions problem

SOLVED
Highlighted
New Member

SecurePro parameter substitutions problem

I am attempting to run a Secure test against a REST service.  It is a POST request and all data is passed in the body.  I have set up a number of variable substitutions in the body and am referencing those in the Secure test setup so that they can be manipulated.

 

When I try to run the Secure test, the transaction log seems to show the parameters being changed for Fuzzing Scan, SQL Injection, etc.  However, the request that goes out uses the original parameter values as defined in the test case.  Has anyone else seen this?

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Manager

Re: SecurePro parameter substitutions problem

@poundei I see that a similar question was submitted previously (https://community.smartbear.com/t5/SoapUI-Pro/SecurePro-parameter-substitutions-are-not-reflected-in...). As far as I understand, the behavior was reported to the Support Team.

Could you please make sure that you are using the last ReadyAPI version? If the issue persists, please reach out to the Customer Care Team.


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today

View solution in original post

2 REPLIES 2
Highlighted
Community Manager

Re: SecurePro parameter substitutions problem

Thank you for posting your question! Let's ask Community for help🙂

 

Anyone faced something similar to this?

@HimanshuTayal @richie @krogold 


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
Community Manager

Re: SecurePro parameter substitutions problem

@poundei I see that a similar question was submitted previously (https://community.smartbear.com/t5/SoapUI-Pro/SecurePro-parameter-substitutions-are-not-reflected-in...). As far as I understand, the behavior was reported to the Support Team.

Could you please make sure that you are using the last ReadyAPI version? If the issue persists, please reach out to the Customer Care Team.


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
TechCorner Leaderboard
Want a fun and easy way to learn ReadyAPI and show off your skills? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Compare an expected JSON value and actual response in Events

Participate!

Fetch value/data from JSON response using Groovy Script

See replies!

Filtering data retrieved from a DataSource

See replies!

Get data from Petstore and add it to Excel sheets

Participate!
Top Kudoed Authors