cancel
Showing results for 
Search instead for 
Did you mean: 

[Resolved] Load Test - with datasource - is this correct ?

New Contributor

[Resolved] Load Test - with datasource - is this correct ?

I'm new to Pro (though have used normal for years). I'm trying to set up a load test of our servers using data driven testing. So I define a datasource initially, then run through the most commonly called services (effectively emulating a user), and then Loop at the bottom back to startup (not up to datasource)



Is this the correct way of doing this for a load test ? When I do get failures - it'll eventually say "Load Test ended" - but I can see requests coming in to the server for several minutes after this and have additional errors in the SoapUI log after this has finished.

Unrelated - I'm also getting an "org.apache.http.conn.HttpHostConnectException - Connection refused." occasionally from the tests (randomly - there's nothing wrong with the request and re-running it is fine). There's nothing in the server logs so I think my question is - is this message is coming from SoapUI (I realise the resolution is external - probably I need to up number of free threads that apache has to work with in this case or there's some issue with my internet connection).
2 REPLIES 2

Re: Load Test - with datasource - is this correct ?

Hi,

It looks OK from what I can see and the information provided. Please check if the datasource is set to "Shared" in the DataSource options dialog. You should try running the load test with 1 thread first and if everything is OK then use multiple threads. Also, please read this link below on DataSources and load tests.


http://www.soapui.org/Data-Driven-Testi ... tests.html


Regards,
Marcus
SmartBear Support

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Contributor

Re: Load Test - with datasource - is this correct ?

Hi Marcus,

Yes that's working fine now - thanks for your help - I did need to mark the datasource as shared.

I discovered that I needed to set the -Djava.net.preferIPv4Stack=true in vmoptions file - this fixed the apache connections issue (I was testing over a uPnP VPN so maybe that's related.

Cheers

- Jon
New Here?
Join us and watch the welcome video:
Top Kudoed Authors