cancel
Showing results for 
Search instead for 
Did you mean: 

ReadyAPI-x64-3.2.0 does not launch in WIN10 64

SOLVED
Highlighted
Occasional Contributor

ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hello friends,

 

First time installation of ReadyAPI-x64-3.2.0 does not launch or Failed to start ReadyAPI in WIN10 64 

 

I've gone through existing solutions but didn't match to my issue. 

 

There is no C:\Users\<UserName>\soapui-settings.xml file to update connection settings.

There is no C:\Users\<UserName>\soapui-workspace.xml file to delete

There are three files postgresql-9.3-1102.jdbc41.jar, sqljdbc42.jar and readme.txt only in

C:\SmartBear\ReadyAPI-3.2.0\bin\ext

 

could you please direct me to right solution.

 

Thanks,

Srini

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hi @ssirapu,

The fact you say when you tried installing v3.1.0 and got the same behaviour as when you installed v3.2.0 is indicative that theres some environmental clash on your laptop.....i.e. ReadyAPI! showing no visible boot up.

I did mention this in my last but i dont think i was clear. When you try and launch ReadyAPI!, if you launch taskmanager (not taskbar), and select the processes tab, does an entry appear equating to ReadyAPI!? Im just wondering that 1. Do you get a ReadyAPI! instance appearing in taskmanager and 2. If there is anything maxing out the resource usage on your laptop. I know pre_fetch on win10 can bring disk usage up to 100% for maybe 10/15mins after boot (along with swap file usage) depending on your setup (especially if youre running an I5 processor) and so if ReadyAPI! startup is sequenced after other stuff thats maxing out your resource usage, it could take a long time to start....perhaps even 20mins (i once had a ReadyAPI! instance on a rubbish VM that took 20mins to boot), but it might still start. So wondering when you say its not starting is it just that it'll take a long time to start but still might.
Whats the spec of your laptop? RAM? processor?

Is the java run time (jdk not jre as i remember i think some groovy needs libraries available only in the jdk not the jre) you have installed 64bit as well? It is essential that the 'bit type' (sorry...dont know the correct term for this) either 64bit or x86 (32bit) of your installed java instance is the same bit type as your ReadyAPI! instance. I thought that Smartbear still made 32bit ReadyAPI! but from the page Rao supplied it doesnt appear so anymore, so just make sure your java is 64bit as well.

Finally if reinstalling hasnt helped, and the other stuff i mentioned doesnt help, id raise a support call to Smartbear (i cant provide the link cos im typing this on my phone, but the support link is at the top of the forum page) .

Hope the comments my have helped,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

11 REPLIES 11
Highlighted
Community Hero

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hi @ssirapu,

Just wondering. Did you do an upgrade (upgrade an existing version and the same program files directory) or did you do a fresh install? (I always do a fresh install when upgrading)

Ive just installed v3.2.0 without any problems on my Win10 64 it laptop. I was previously running v3.1.0

I have the soapui-settings.xml file and default-soapui-workspace.xml files in C://Users/Rich directory. Those 3 files (the 2 .jars and the .txt) were successfully created in bin/ext directory in the program files directory too.

Id double check if the .xml files (settings and workspace) are definitely not present or not.....the files arent hidden (beginning with a period/fullstop) so they should definitely be displayed whatever the file/folder view permissions are set (unless you dont have local admin or its a networked laptop and Group Policy is hindering viewing your profile), but i'm wondering if youre just not seeing them because perhaps your windows file/folder view permissions arent displaying extensions including type .xml???

Have you noticed when you attempt to launch ReadyAPI! ehat happens in taskmanager.... do you get a ReadyAPI! entry in taskmanager when you try and launch?

At this point, whatever your answers are to my above questions i think id try and reinstall v3.2.0 to the same directory and go from there.

Cheers,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Occasional Contributor

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hi Rich,

Thanks for the prompt response.

1. Its not an upgrade, I've same issue with both versions ReadyAPI-x64-3.1 and ReadyAPI-x64-3.2

2. Nothing appear in Taskbar related to ReadyAPI 

3. soapui-settings.xml and default-soapui-workspace.xml files are not available, I cross checked  after enable show hidden files and extensions.

4 I've local admin rights to install and to change folder permissions.

 

One thing I noticed, If I click on batch file ‪C:\SmartBear\ReadyAPI-3.2.0\bin\ready-api.bat, then launches but no use because nothing save ( projects including licence key info) after reopen through batch file.

 

any other clues, please advise?

Thanks,

Srini

 

 

Highlighted
Community Hero

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Which installer file are you using to install?


Regards,
Rao.
Highlighted
Occasional Contributor

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

I've downloaded Windows installer (64-bit) from the below url

https://support.smartbear.com/downloads/readyapi/

Thanks,

Srini

Highlighted
Community Hero

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hi @ssirapu,

The fact you say when you tried installing v3.1.0 and got the same behaviour as when you installed v3.2.0 is indicative that theres some environmental clash on your laptop.....i.e. ReadyAPI! showing no visible boot up.

I did mention this in my last but i dont think i was clear. When you try and launch ReadyAPI!, if you launch taskmanager (not taskbar), and select the processes tab, does an entry appear equating to ReadyAPI!? Im just wondering that 1. Do you get a ReadyAPI! instance appearing in taskmanager and 2. If there is anything maxing out the resource usage on your laptop. I know pre_fetch on win10 can bring disk usage up to 100% for maybe 10/15mins after boot (along with swap file usage) depending on your setup (especially if youre running an I5 processor) and so if ReadyAPI! startup is sequenced after other stuff thats maxing out your resource usage, it could take a long time to start....perhaps even 20mins (i once had a ReadyAPI! instance on a rubbish VM that took 20mins to boot), but it might still start. So wondering when you say its not starting is it just that it'll take a long time to start but still might.
Whats the spec of your laptop? RAM? processor?

Is the java run time (jdk not jre as i remember i think some groovy needs libraries available only in the jdk not the jre) you have installed 64bit as well? It is essential that the 'bit type' (sorry...dont know the correct term for this) either 64bit or x86 (32bit) of your installed java instance is the same bit type as your ReadyAPI! instance. I thought that Smartbear still made 32bit ReadyAPI! but from the page Rao supplied it doesnt appear so anymore, so just make sure your java is 64bit as well.

Finally if reinstalling hasnt helped, and the other stuff i mentioned doesnt help, id raise a support call to Smartbear (i cant provide the link cos im typing this on my phone, but the support link is at the top of the forum page) .

Hope the comments my have helped,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

Highlighted
Occasional Contributor

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hi @richie,, Thank you for coming back with suggestions.

 

I just noticed ReadyAPI disappear in "TaskManager" in less than few seconds.

I installed JDK (jdk-14.0.1_windows-x64_bin.exe), and set to path variable as well.var.PNGtask.PNGjav.PNG

 

 

 

readyapi.PNG

Am I missing something, please advise?

 

Thanks,

Srini

 

 

Highlighted
Community Hero

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

How is it showing 1.8 when 14 is set in environment variables?


Regards,
Rao.
Highlighted
Community Hero

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hi @ssirapu,

Good spot by Rao there. It looks like you already had jre/jdk 8 installed and then installed v14 (which is totally fine...i have several versions or java on my laptop), but your config hasnt picked up your latest java install.

I found a couple of links for similar issues with ubuntu and MacOS, but id still have a look at these (despite being on different operating systems) and make the changes suggested just in case (disable the internal browser and set the additional config settings)

Internal browser https://community.smartbear.com/t5/SoapUI-Open-Source/soapUI-startup-crash/td-p/132854

Soapui-settings.xml
https://community.smartbear.com/t5/SoapUI-Pro/Failed-to-start-ReadyAPI-error-on-launch/td-p/196424


You mention the Path variable i think (which youve screenshotted i think). You definitely need to update your Path variable to point to your jdk (so the OS knows where your java is), but it doesnt appear to be working which is i suspect why when you check the version the OS is looking for (via 'java -version' at command prompt) it finds v8 rather than v14, so that needs looking at, although running on v8 shouldnt be a problem.

However the big thing i noticed from your screenshot of what i think is the Path variable is that its virtually empty. The Path variable always has multiple rows in there.....i have about 20 entries....you have 2 including the latest jdk14!

Can you please screenshot the contents of your soapui-settings.xml file, your vmoptions file, contents of your Path and Classpath env variables and screenshot the list of env variables (just wondering if you have anything like java_home or jre_home set) so we can see what you have installed?

The fact that ReadyAPI! appears to suffer an exception severe enough to immediately shutdown after attempting to start means i dont think much will get written to the ReadyAPI! logs. We cant access the logging via the app obviously, but you can check the log files themselves. On my machine theyre in C://Users/Rich/.readyapi/logs
Have a look at the 'ready-api-errors.log' and 'ready-api.log' and can you also attach these to your next response.

The only alternative to checking the readyapi! logs to determine the issue is actually checking Windows Event Viewer. Its been years and years aince i used this to try and resolve a problem and even then the problem was an MS application (SQLSERVER). There might be something generated in the windows logs folder of event viewer, but i need to do a bit of research on this....i.e. an error might get written to this which indicates what the problem relates to. I dont know for certain, but i doubt event viewer will include events from readyapi!, but as i think theres a conflict with another component on your laptop, this conflicted component might cause an event to get written to the event viewer.

I'll do a bit of reading about event viewer just in case we need to resort to this.

Cheers!

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Occasional Contributor

Re: ReadyAPI-x64-3.2.0 does not launch in WIN10 64

you are a star @richie  Thanks a lot 

 

Solution:

Is the java run time (jdk not jre as i remember i think some groovy needs libraries available only in the jdk not the jre)

Yes issue has been fixed after remove default jre runtime and set to JDK.

 

@nmraoThank you for spoting default settings 

 

 

New Here?
Join us and watch the welcome video:
Announcements
Script Wanted
The new challenge is here!

Create a script to сhange an XPath Match assertion to a JSONPath Match assertion for the TechCorner tag!


Scripts created in July:
- A script to generate an email when an assertion fails
- A script to change the request body before sending it to the server
Top Kudoed Authors