cancel
Showing results for 
Search instead for 
Did you mean: 

ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

New Contributor

ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

I have Kerberos authenticated webservice deployed in application server. By following steps in below url I am able to setup Spaui 5.30 version for kerberos testing. However in the same system ReadyAPI is throwing unaauthorized error. I have done all the corresponding steps for ReadyAPI also. 

https://www.soapui.org/soap-and-wsdl/spnego/kerberos-authentication.html

In the same client machine it is working in Java client also. Only ReadyAPI not working.

Please help me to solve this issue.

 

Regards,

Arul

 

 

7 REPLIES 7
Moderator

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

Hi Arulkumar,

 

Thank you for your post. Please compare Raw requests from SoapUI 5.3.0 and Ready! API. Maybe the "Authorization" header in the Ready! API request is missing.

 

To get a Raw request in Ready! API, please choose the Raw tab in the left request. See an example: http://screencast.com/t/5zWSX2Y9.


Anastasia
Customer Care Team

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
2016-12-19_1414
Free online storage and sharing with Screencast.com. 2 GB of storage and 2 GB of bandwidth per month for free. We won't compress, alter or take ownership of your content.
New Contributor

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

Hi Anastasia,

 

Thanks for the response. As you told there is no authorization header in the Raw request of ReadyAPI. However even after selecting Raw tab in the request I am getting same error. Please see attached screen shots of ReadyAPI and SoapUI and let me know your thoughts.

 

Thanks & Regards,

Arul

Moderator

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

Hi Arul,

 

Please enable the "Authenticate preemptively" option in Ready! API Preferences > HTTP: http://www.screencast.com/t/rXRr09P9.


Anastasia
Customer Care Team

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
New Contributor

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

Hi Anastasia,

I enabled that option but I still don't see the Authentication header under the Raw tab?

Moderator

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

Hi ayusuf, 

 

Do you use the Kerberos authentication? If so, here is the documentation for this type: https://support.smartbear.com/readyapi/docs/projects/requests/auth/types/spnego.html 


Anastasia
Customer Care Team

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
Highlighted
New Contributor

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

Hi Anastasia,

Yes, I'm using SPNEGO/Kerberos (Built-in) as my authorization. I know the request is working because when I remove the Kerberos ticket from my user directory the request fails.  

Moderator

Re: ReadyAPI throws 401 unauthorized error when accessing kerberos authenticated wsdl.

What version of ReadyAPI do you use?


Anastasia
Customer Care Team

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
New Here?
Join us and watch the welcome video:
Watch the new Interview
Top Kudoed Authors