cancel
Showing results for 
Search instead for 
Did you mean: 

ReadyAPI 2.7 trial version giving blank screen

SOLVED
New Contributor

ReadyAPI 2.7 trial version giving blank screen

I installed ReadyAPI 2.7 trial version by registering, when i tried to launch ReadyAPI we are getting blank screen

 

please help on this.....

 

Below is the ReadyAPI Log

 

Mon Jul 01 11:43:43 IST 2019: INFO: ReadyAPI 2.7.0 (build 3010) started - System properties: {OS=Windows 10, User name=abc}
Mon Jul 01 11:43:43 IST 2019: INFO: SoapUI settings were initialized from [C:\Users\abc\soapui-settings.xml]
Mon Jul 01 11:43:43 IST 2019: INFO: "C:\Program Files\SmartBear\ReadyAPI-2.7.0\bin\ext\postgresql-9.3-1102.jdbc41.jar" has been added to the classpath.
Mon Jul 01 11:43:43 IST 2019: INFO: "C:\Program Files\SmartBear\ReadyAPI-2.7.0\bin\ext\sqljdbc42.jar" has been added to the classpath.
Mon Jul 01 11:43:43 IST 2019: INFO: 2 JDBC drivers have been registered from the directory bin/ext: [org.postgresql.Driver, com.microsoft.sqlserver.jdbc.SQLServerDriver].
Mon Jul 01 11:43:44 IST 2019: INFO: Adding listeners from [C:\Program Files\SmartBear\ReadyAPI-2.7.0\bin\listeners\demo-listeners.xml]
Mon Jul 01 11:43:46 IST 2019: INFO: Adding actions from [C:\Program Files\SmartBear\ReadyAPI-2.7.0\bin\actions\demo-actions.xml]
Mon Jul 01 11:43:48 IST 2019: DEBUG: Trying to initialize license for SoapUI
Mon Jul 01 11:43:48 IST 2019: DEBUG: No license found for SoapUI
Mon Jul 01 11:43:48 IST 2019: DEBUG: License host for SoapUI: WKWIN0522513
Mon Jul 01 11:43:48 IST 2019: DEBUG: Trying to initialize license for SoapUI
Mon Jul 01 11:43:48 IST 2019: DEBUG: License host for SoapUI: WKWIN0522513
Mon Jul 01 11:43:48 IST 2019: DEBUG: Valid license file found: C:\Users\abc\.soapui\soapui.key, last modified: 2019-07-01T10:24:15.479+0530
Mon Jul 01 11:43:48 IST 2019: DEBUG: Trying to initialize license for Secure
Mon Jul 01 11:43:48 IST 2019: DEBUG: No license found for Secure
Mon Jul 01 11:43:48 IST 2019: DEBUG: License host for Secure: WKWIN0522513
Mon Jul 01 11:43:48 IST 2019: DEBUG: Trying to initialize license for LoadUI
Mon Jul 01 11:43:48 IST 2019: DEBUG: Valid license file found: C:\Users\abc\.loadui\loadUI.key, last modified: 2019-07-01T10:24:15.518+0530
Mon Jul 01 11:43:48 IST 2019: DEBUG: License host for LoadUI: WKWIN0522513
Mon Jul 01 11:43:49 IST 2019: DEBUG: Trying to initialize license for ServiceV
Mon Jul 01 11:43:49 IST 2019: DEBUG: Valid license file found: C:\Users\abc\.readyapi\servicev.key, last modified: 2019-07-01T10:24:15.483+0530
Mon Jul 01 11:43:49 IST 2019: INFO: Loading workspace from [C:\Users\abc\default-soapui-workspace.xml]
Mon Jul 01 11:43:49 IST 2019: DEBUG: License host for ServiceV: WKWIN0522513
Mon Jul 01 11:43:49 IST 2019: INFO: Adding plugin from [C:\Users\abc\.soapui\plugins\ready-jira-plugin-1.3.jar]
Mon Jul 01 11:43:49 IST 2019: INFO: Adding plugin from [C:\Users\abc\.soapui\plugins\ready-mqtt-plugin-dist.jar]
Mon Jul 01 11:43:50 IST 2019: INFO: Setting the maximum size of the dashboard database to 6144 MB.
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPrefs]
Added AutoFactory for [PluginTestStep]
Added AutoFactory for [PluginTestStep]
Added AutoFactory for [PluginTestStep]
Mon Jul 01 11:43:52 IST 2019: INFO: Adding plugin from [C:\Users\abc\.soapui\plugins\ready-uxm-plugin-1.1.0.jar]
Added AutoFactory for [PluginPrefs]
Mon Jul 01 11:43:52 IST 2019: INFO: 3 plugins loaded in 3210 ms
Mon Jul 01 11:43:52 IST 2019: INFO: All plugins loaded
Mon Jul 01 11:43:53 IST 2019: INFO: Loaded project from [file:/C:/Users/abc/Documents/SOAP-soapui-project.xml]
Mon Jul 01 11:43:53 IST 2019: INFO: Loaded project from [file:/C:/Users/abc/Documents/Project-1-soapui-project.xml]
Mon Jul 01 11:43:55 IST 2019: INFO: Initialized base directory to keep executions to C:\Users\abc\.readyapi\loadui\results
Mon Jul 01 11:43:55 IST 2019: INFO: Initializing modules
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Mon Jul 01 11:43:56 IST 2019: INFO: Module [Dashboard] added 0 actionGroups, 0 actions, 0 factories, 0 listeners, 0 toolbar components.
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Mon Jul 01 11:43:56 IST 2019: INFO: Module [LoadUI] added 6 actionGroups, 14 actions, 3 factories, 0 listeners, 0 toolbar components.
Mon Jul 01 11:43:56 IST 2019: INFO: Module [Secure] added 5 actionGroups, 13 actions, 2 factories, 0 listeners, 0 toolbar components.
Added AutoFactory for [PluginPanelBuilder]
Mon Jul 01 11:43:56 IST 2019: INFO: Module [Integrations] added 0 actionGroups, 0 actions, 0 factories, 0 listeners, 0 toolbar components.
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginPanelBuilder]
Added AutoFactory for [PluginRequestInspector]
Added AutoFactory for [PluginResponseInspector]
Added AutoFactory for [PluginResponseInspector]
Mon Jul 01 11:43:58 IST 2019: INFO: Module [SoapUI] added 6 actionGroups, 6 actions, 1 factories, 0 listeners, 0 toolbar components.
Mon Jul 01 11:43:59 IST 2019: INFO: Module [Projects] added 12 actionGroups, 2 actions, 1 factories, 0 listeners, 0 toolbar components.
Mon Jul 01 11:43:59 IST 2019: INFO: Module [SoapUIProUserInterfaceModule] added 5 actionGroups, 208 actions, 3 factories, 0 listeners, 0 toolbar components.
Mon Jul 01 11:43:59 IST 2019: INFO: Module [ServiceV] added 19 actionGroups, 36 actions, 19 factories, 0 listeners, 0 toolbar components.
Mon Jul 01 11:43:59 IST 2019: INFO: All modules loaded
Mon Jul 01 11:43:59 IST 2019: INFO: Module [ReadyApiUI] added 6 actionGroups, 4 actions, 0 factories, 0 listeners, 0 toolbar components.
Mon Jul 01 11:43:59 IST 2019: INFO: Loading took 4253 ms
Mon Jul 01 11:43:59 IST 2019: INFO: Setting maximum test history db size to 2048 MB
Mon Jul 01 11:43:59 IST 2019: INFO: Setting the maximum size of the dashboard database to 6144 MB.
Mon Jul 01 11:44:01 IST 2019: INFO: Starting ReadyAPI 2.7.0 (build 3010)
Mon Jul 01 11:44:03 IST 2019: ERROR: Failed to start IPC process.
com.teamdev.jxbrowser.chromium.internal.ipc.IPCException: Failed to start IPC process.
at com.teamdev.jxbrowser.chromium.internal.ipc.d.run(SourceFile:200)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: java.io.IOException: Cannot run program "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21\browsercore64.exe" (in directory "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21"): CreateProcess error=5, Access is denied
at com.teamdev.jxbrowser.chromium.internal.ipc.ExternalChromiumProcess.doStart(SourceFile:82)
at com.teamdev.jxbrowser.chromium.internal.ipc.ChromiumProcess.start(SourceFile:235)
at com.teamdev.jxbrowser.chromium.internal.ipc.d.run(SourceFile:193)
... 1 more
Caused by: java.io.IOException: Cannot run program "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21\browsercore64.exe" (in directory "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21"): CreateProcess error=5, Access is denied
at java.lang.ProcessBuilder.start(Unknown Source)
at com.teamdev.jxbrowser.chromium.internal.ipc.ExternalChromiumProcess.doStart(SourceFile:71)
... 3 more
Caused by: java.io.IOException: CreateProcess error=5, Access is denied
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 5 more
Mon Jul 01 11:44:03 IST 2019: ERROR: Failed to start IPC process.
com.teamdev.jxbrowser.chromium.internal.ipc.IPCException: Failed to start IPC process.
at com.teamdev.jxbrowser.chromium.internal.ipc.d.run(SourceFile:200)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: java.io.IOException: Cannot run program "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21\browsercore64.exe" (in directory "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21"): CreateProcess error=5, Access is denied
at com.teamdev.jxbrowser.chromium.internal.ipc.ExternalChromiumProcess.doStart(SourceFile:82)
at com.teamdev.jxbrowser.chromium.internal.ipc.ChromiumProcess.start(SourceFile:235)
at com.teamdev.jxbrowser.chromium.internal.ipc.d.run(SourceFile:193)
... 1 more
Caused by: java.io.IOException: Cannot run program "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21\browsercore64.exe" (in directory "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21"): CreateProcess error=5, Access is denied
at java.lang.ProcessBuilder.start(Unknown Source)
at com.teamdev.jxbrowser.chromium.internal.ipc.ExternalChromiumProcess.doStart(SourceFile:71)
... 3 more
Caused by: java.io.IOException: CreateProcess error=5, Access is denied
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 5 more

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: ReadyAPI 2.7 trial version giving blank screen

Hi @arunsarode 

 

the logging at when you boot ReadyAPI! is identical (more or less) to mine until it gets to here:

 

Mon Jul 01 11:44:03 IST 2019: ERROR: Failed to start IPC process.
com.teamdev.jxbrowser.chromium.internal.ipc.IPCException: Failed to start IPC process.
at com.teamdev.jxbrowser.chromium.internal.ipc.d.run(SourceFile:200)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: java.io.IOException: Cannot run program "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21\browsercore64.exe" (in directory "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21"): CreateProcess error=5, Access is denied

I haven't got much of a suggestion - but if I were you I'd raise a tech support request with SmartBear.

 

There was another user that appears to have had a similar/equivalent issue - but he was running Linux x64 - he added/updated a couple of .jar libraries and this resolved his issue - but that was a different operating system (link) - unfortunately there wasn't anything on the link to indicate how he diagnosed the problem - but you both have issues with the jxbrowser component.....

 

Yeah - unless anyone else has any opinions I'd raise the service request.

 

Sorry I can't be of more help,

 

rich

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
10 REPLIES 10
Community Leader

Re: ReadyAPI 2.7 trial version giving blank screen

@arunsarode 

 

Can you attach any screenshot. So that it will be more clear.

 


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" Smiley Happy

Thanks and Regards,
Himanshu Tayal
Community Hero

Re: ReadyAPI 2.7 trial version giving blank screen

Hi @arunsarode 

 

the logging at when you boot ReadyAPI! is identical (more or less) to mine until it gets to here:

 

Mon Jul 01 11:44:03 IST 2019: ERROR: Failed to start IPC process.
com.teamdev.jxbrowser.chromium.internal.ipc.IPCException: Failed to start IPC process.
at com.teamdev.jxbrowser.chromium.internal.ipc.d.run(SourceFile:200)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: java.io.IOException: Cannot run program "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21\browsercore64.exe" (in directory "C:\Users\abc\AppData\Local\JxBrowser\browsercore-64.0.3282.24.6.21"): CreateProcess error=5, Access is denied

I haven't got much of a suggestion - but if I were you I'd raise a tech support request with SmartBear.

 

There was another user that appears to have had a similar/equivalent issue - but he was running Linux x64 - he added/updated a couple of .jar libraries and this resolved his issue - but that was a different operating system (link) - unfortunately there wasn't anything on the link to indicate how he diagnosed the problem - but you both have issues with the jxbrowser component.....

 

Yeah - unless anyone else has any opinions I'd raise the service request.

 

Sorry I can't be of more help,

 

rich

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
Moderator

Re: ReadyAPI 2.7 trial version giving blank screen

Hi all,

 

@arunsarode, do you have any updates? Did the link to the Community topic that Rich provided help?
In case you decide to raise a support ticket, please follow this link: https://support.smartbear.com/message/?prod=ReadyAPI

We are looking forward to hearing from you.

 


Olga Terentieva
SmartBear Assistant Community Manager

New Contributor

Re: ReadyAPI 2.7 trial version giving blank screen

@richie 

Thanks for you reply

Highlighted
Contributor

Re: ReadyAPI 2.7 trial version giving blank screen

We're experiencing a very similar, if not exact, issue with the same blank screen result. We're using Windows 10 Enterprise (build 1809) with Java 8 update 211 and JRE 8 update 211. This began, for us, on Monday, July 8th. I submitted a ticket and the initial response was to uninstall and reinstall; however, reinstallation process would not complete and presented an "Error 20" pop-up. Ugh!

It wasn't until our local tech support did some brief web searching to find that Java may have been negatively impacting the installation that we were able finish the install and get back to the original blank screen issue. The recommendation was to uninstall Java 8 Update 211 and JRE Update 211. What version of Java or Jre is required?

 

Attached is a post install log file, but this error stands out:
"Thu Jul 11 14:42:14 PDT 2019: ERROR: Failed to initialize or establish a connection with a Chromium render process. You are observing this exception as the render process didn't respond within 120 seconds after the Browser constructor has been invoked."

Community Hero

Re: ReadyAPI 2.7 trial version giving blank screen

Hi,

 

I'm using 1.8.0_144 (Java 8 update 144) and I don't get the blank screen

 

It looks like there has been another update since you installed your java version (Java 8 update 212).  Obviously I don't know if this latest version will resolve your problem - but as I say I don't get the blank screen with my version.

 

The Java Downloads Archive (to download previous versions of Java) link is here

 

cheers,

 

rich

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
Contributor

Re: ReadyAPI 2.7 trial version giving blank screen

Thank you, Richie. Unfortunately, I'm not in full control of what version of Java and Jre that can be loaded on my work machine due to security reasons. As odd as it might sound, I may be able to go backward in version, but may not be able to upgrade versions. I'll see what I can do though.

Contributor

Re: ReadyAPI 2.7 trial version giving blank screen

FYI. We've determined that McAfee's Host Intrusion Prevention System (HIPS) is the cause of this issue for us.

Community Hero

Re: ReadyAPI 2.7 trial version giving blank screen

Hey @socaltester 

 

if your policy inhibits updating yoru java runtime i wouldve thought there's no way you can disable your AV.

 

Curious - how are you going to handle this?

 

ta,

 

rich

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
New Here?
Join us and watch the welcome video:
Top Kudoed Authors