cancel
Showing results for 
Search instead for 
Did you mean: 

Ready API 2.3 Error This driver is not configured for integrated authentication.

SOLVED
Highlighted
New Contributor

Ready API 2.3 Error This driver is not configured for integrated authentication.

Hi,

I'm using Ready API version 2.3.0

 

This is my set up

  •  placed mssql-jdbc_auth-8.2.2.x64.dll inside C:\Program Files\SmartBear\ReadyAPI-2.3.0\bin
  • placed sqljdbc42.jar inside folder C:\Program Files\SmartBear\ReadyAPI-2.3.0\bin\ext
  • Restarted the ReadyAPI
  • Added Driver: com.microsoft.sqlserver.jdbc.SQLServerDriver
    Connection String: jdbc:microsoft:sqlserver://server:portname;databaseName=db name;IntegratedSecurity=true

But during test connection keep getting error: Can't get the Connection for specified properties; com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Hey @UserUnknown,

What is the authentication scheme used to login to your sqlserver database?
NTLM (windows domain) auth?
Mixed mode auth?
SQL auth?

If youre using NTLM, then youll need the auth.dll.

Can you login to enterprise manager to check what authentication is used (and perhaps change it if necessary)? The auth type is defined in sqlservers enterprise manager.

You mention the connection string youre using has changed. Youve removed the word 'microsoft', and integratedSecurity parameter and added in the password parameter. Did you alter the existing connection string or did you add in a new one?

The reason im asking about the URL is that the error response is "Login failed for user 'id'" and im guessing your database's username is NOT 'id', so i'm wondering why this has been picked up.

For example my local sqlserver db connection string details are as follows:

jdbc:sqlserver://127.0.0.1:1433;DatabaseName=ExtReference;user=sa;password=whatevs

In summary: its essential to determine the authentication type of the database youre trying to connect to before you try anything as this will guide thr rest of your setup.

Nice one,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

4 REPLIES 4
Highlighted
Community Hero

Hi UserUnknown,

I tried this about a year ago and couldnt set it up in ReadyAPI! with NTLM auth (which is why youve put the auth.dll into the bin directory).

I eventually decided to use sql auth instead (which doesnt require the dll) and i setup the connection no problem.

Ok. Ivr just checked my ReadyAPI! setup.
My default sqlserver connection string is different (although we are running different versions...im on v3.2)
Did you setup your jdbc connection string or are you using the default.

Im using sql auth, so a little different, but my sqlserver connection string (which is the default version) is as follows:

jdbc:sqlserver://<HOST:127.0
0.1>:<PORT:1433>;databaseName=<DB>;user=<USER>;password=<PASSWORD>

My connection string is different to yours is "jdbc:microsoft:sqlserver://server:portname;databaseName=db name;IntegratedSecurity=true"

I.e.you mention microsoft at the start which doesnt include, you dont provide a password and i dont have integratedSecurity parameter.
Are you sure these differences are correct and you must use them if you need NTLM auth?

Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
New Contributor

I made few changes to my set up.

Removed mssql-jdbc_auth-8.2.2.x64.dll from C:\Program Files\SmartBear\ReadyAPI-2.3.0\bin

This is my Driver: MSSQL(MS)/com.microsoft.sqlserver.jdbc.SQLServerDriver

Connection String: jdbc:sqlserver://<servername>:1433;DatabaseName=<Name>;user=<id>;password=<password>

 

And now I get following error: 

Can't get connection for specified properties
com.microsoft,jdbc.SQLServerException: Login failed for user 'id'

Highlighted
Community Hero

Hey @UserUnknown,

What is the authentication scheme used to login to your sqlserver database?
NTLM (windows domain) auth?
Mixed mode auth?
SQL auth?

If youre using NTLM, then youll need the auth.dll.

Can you login to enterprise manager to check what authentication is used (and perhaps change it if necessary)? The auth type is defined in sqlservers enterprise manager.

You mention the connection string youre using has changed. Youve removed the word 'microsoft', and integratedSecurity parameter and added in the password parameter. Did you alter the existing connection string or did you add in a new one?

The reason im asking about the URL is that the error response is "Login failed for user 'id'" and im guessing your database's username is NOT 'id', so i'm wondering why this has been picked up.

For example my local sqlserver db connection string details are as follows:

jdbc:sqlserver://127.0.0.1:1433;DatabaseName=ExtReference;user=sa;password=whatevs

In summary: its essential to determine the authentication type of the database youre trying to connect to before you try anything as this will guide thr rest of your setup.

Nice one,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

Highlighted
Community Manager

Thanks for the suggestion, Richie!

 

@UserUnknown, does it help your resolve the issue? 

---------
Tanya Gorbunova
SmartBear Community Manager

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
New Here?
Join us and watch the welcome video:
Announcements
TechCorner Leaderboard
Want a fun and easy way to learn ReadyAPI and show off your skills? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Get a full Raw JMS request

Participate!

Compare an expected JSON value and actual response in Events

Participate!

Fetch value/data from JSON response using Groovy Script

See replies!

Get data from Petstore and add it to Excel sheets

Participate!
Top Kudoed Authors