cancel
Showing results for 
Search instead for 
Did you mean: 

Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

SOLVED
New Contributor

Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

I need use Chinese Chars in SoapUI Pro [DataSource Step] - [Data Connection] - [SQL Query] command, but it shows junk characters here and the query result is null, how to handle this issue?

 

The SQL Query as below:

Select configs_account.id As accountId
From configs_account
Where configs_account.name = Trim("${GetTestData#name}")

 

=>

 

Select configs_account.id As accountId
From configs_account
Where configs_account.name = Trim("apitest_ValidData_使用中文作为名称")

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

Hi @HimanshuTayal 

 

looking at the screenshots, @白夜有点黑  is using SoapUI, you're using ReadyAPI - hence the difference in character rendering.

 

@白夜有点黑 what version are you using?  You'll probably have to upgrade to a more recent version of SoapUI or ReadyAPI! to resolve this.

 

Cheers,

 

richie

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
4 REPLIES 4
Regular Contributor

Re: Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

Hi @白夜有点黑 ,

 

I have tried your scenario, but it is not showing me any error.

Please refer attached screenshot


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" Smiley Happy

Thanks and Regards,
Himanshu Tayal
Highlighted
Community Hero

Re: Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

Hi @HimanshuTayal 

 

looking at the screenshots, @白夜有点黑  is using SoapUI, you're using ReadyAPI - hence the difference in character rendering.

 

@白夜有点黑 what version are you using?  You'll probably have to upgrade to a more recent version of SoapUI or ReadyAPI! to resolve this.

 

Cheers,

 

richie

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the title of the post to something more descriptive? This will help people when searching for problems.
Regular Contributor

Re: Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

Hi @richie ,

 

Might be the reason Smiley Happy

 

 


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" Smiley Happy

Thanks and Regards,
Himanshu Tayal
Community Manager

Re: Junk characters in SoapUI [DataSource] - [Data Connection] - [SQL Query] , how to handle this?

Thanks for your suggestions, guys,

@白夜有点黑, was the question resolved? If it was, select the best answer so that it can be found easily in the future.

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Here?
Join us and watch the welcome video:
Top Kudoed Authors