cancel
Showing results for 
Search instead for 
Did you mean: 

Increasing Memory for SoapUI on Mac

Highlighted
Contributor

Increasing Memory for SoapUI on Mac

Hi,

I have been getting significant performance problems when running soapUI NG on my Mac. I was provided what appears to be a pretty useful resource here:

 

http://readyapi.smartbear.com/soapui/working/improving_memory_usage#_ga=1.28329340.150906264.1449587...

 

However, it indicates that to adjust memory settings on a mac, you need to update "Contents/vmoptions.txt". I cannot find this file anywhere, nor the relavent "Contents" directory. In fact, on my ReadyAPI installation, anything meaningful from a config or bin or library perspective seems to be in this HermesJMS folder, and this frustratingly seems to have no SoapUI references at all.

 

Any idea how do address this on a mac is greatly appreciated. Thank you

2 REPLIES 2
Community Manager

Re: Increasing Memory for SoapUI on Mac

Hi Tclotworthy,

 

Please refer to the following article to learn how to get access to the Contents folder:

http://readyapi.smartbear.com/readyapi/dirs/intro/mac

---------
Tanya Gorbunova
SmartBear Community Manager

Join the September Hub-bub to show off, learn and win
Contributor

Re: Increasing Memory for SoapUI on Mac

Hi Tanya,

 

Your response allowed me to find the contents folder and related vmoptions.txt file. Unfortunately when following the directions for adjusting the memory, I ran into another issue.

 

The article I was directed to for improving memory usage was here Improving Memory Usage . For mac, it said

 

Adjust Memory Settings


This doesn't really solve the underlying problem, but if you have large WSDLs, requests, attachments, and so on the default settings in bin\soapui.bat, bin\soapui.sh, bin\vmoptions for Windows or Contents/vmoptions.txt for Mac won't be sufficient.

Open the corresponding file in a text editor and change the line

 

set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx256m -Dsoapui.properties=soapui.properties

 

to use higher values for the max allocated size, for example:

 

set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx768m -Dsoapui.properties=soapui.properties

 

 

However, when I open the Contents/vmoptions.txt file does not have the JAVA_OPTS line (as shown above) to even change it. Therefore, I simply added the recommended second line. But when I attempt to restart ReadAPI, it will not even boot. Therefore, I have simply removed the line and am now back where I started with the original memory issues.

 

New Here?
Join us and watch the welcome video:
Join the exciting event
SeptemberHubBub
Top Kudoed Authors
Join the September Hub-bub to show off, learn and win