cancel
Showing results for 
Search instead for 
Did you mean: 

How to set using insecure ssl in SoapUI?

SOLVED
Highlighted
New Contributor

How to set using insecure ssl in SoapUI?

When I call a request:
POST https://xxxx/users/login?username=xxx&password=xxx

The response is:
<data contentType="null" contentLength="0"><![CDATA[]]></data>

The error is:
Error getting response; javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

It is because my server doesn't have a valid SSL certificate, so can anyone tell me how to set using insecure ssl in SoapUI in order to get the right response?
Thank you in advance!
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator

Re: How to set using insecure ssl in SoapUI?

If your self-signed certificate is in the Windows Personal Certificate Store you need to check the "Certificate Store" checkbox in Preferences > SSL.


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

4 REPLIES 4
Highlighted
Moderator

Re: How to set using insecure ssl in SoapUI?

Hello,

Please configure the ssl preferences in SoapUI by going to File -> Preferences -> SSL Settings.

Please reference link below:
http://www.soapui.org/Working-with-soap ... ttings-tab


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
New Contributor

Re: How to set using insecure ssl in SoapUI?

mrJames wrote:
Hello,

Please configure the ssl preferences in SoapUI by going to File -> Preferences -> SSL Settings.

Please reference link below:
http://www.soapui.org/Working-with-soap ... ttings-tab



Could you give me some specific config method to disable the secure ssl checking?
Highlighted
New Contributor

Re: How to set using insecure ssl in SoapUI?

I'm having the same problem, and the linked reference to the SSL Settings page is about as bad an answer as you can give.

Where exactly on that page does it describe how to disable host checking? Which setting, specifically, denotes that SoapUI will not refuse a connection due to a self-signed certificate on the server?

And considering SoapUI is frequently used as a dev testing tool, why in the hell would it perform strict checking in the first place?!? Who pays for a signed certificate on a dev machine?

This is seriously infuriating, and I'm ready to chuck soapui altogether...
Highlighted
Moderator

Re: How to set using insecure ssl in SoapUI?

If your self-signed certificate is in the Windows Personal Certificate Store you need to check the "Certificate Store" checkbox in Preferences > SSL.


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Top Kudoed Authors