cancel
Showing results for 
Search instead for 
Did you mean: 

HTTP/1.1 400 Proxy error

SOLVED
New Contributor

HTTP/1.1 400 Proxy error

Need help with this error. After talking with my Network team, I was told that we do not have Proxy Servers.  I set the Proxy Settings to None in SOAPUI.  I am getting the following error when trying to execute a SOAP request generated from the WSDL:

 

HTTP/1.1 400 Proxy error
Transfer-Encoding: chunked
Content-Type: text/plain
Server: Microsoft-IIS/8.5
X-FourJs-Server: GAS/2.50.50-154989
X-Powered-By: ASP.NET
Date: Fri, 15 Feb 2019 16:02:04 GMT

Proxy encountered error during request processing

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: HTTP/1.1 400 Proxy error

Hey!

 

I think the 'proxy error' is steering you in the wrong direction - I think the developers who developed the app have gotten their exception handling muddled - 400 is a bad request/malformed request, not relevant to a proxy and this is backed by your network guys.

 

So - there's a problem with either the SOAP envelope or the payload within the SoapBody tag.

 

If you can publish the SOAP request and response and the .wsdl and .xsd - we should be able to identify what went wrong!

 

Cheers,

 

richie

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

2 REPLIES 2
Highlighted
Community Hero

Re: HTTP/1.1 400 Proxy error

Hey!

 

I think the 'proxy error' is steering you in the wrong direction - I think the developers who developed the app have gotten their exception handling muddled - 400 is a bad request/malformed request, not relevant to a proxy and this is backed by your network guys.

 

So - there's a problem with either the SOAP envelope or the payload within the SoapBody tag.

 

If you can publish the SOAP request and response and the .wsdl and .xsd - we should be able to identify what went wrong!

 

Cheers,

 

richie

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

New Contributor

Re: HTTP/1.1 400 Proxy error

Richie,

  You were correct - the reponse from the web service was misleading.  After investigating a little further, I found the that some of the xml tags were expected to be passed as CDATA (not sure why since they are all processed by the web service as xml tags).  After adjusting the Request to handle some of the tags as CDATA all is well.

Thanks for your response.

Doug.